Survey banner
The Dataiku Community is moving to a new home! Some short term disruption starting next week: LEARN MORE

Forecast Plugin Timeformat

Level 2
Forecast Plugin Timeformat


i am using the dataiku forecast plugin and came across some issues related to the dateformat and its recognition by the forecast plugin.

When i tried to create the environment i got the error:

- dataiku Job failed: Error in R process: simpleError : there is no package called ‘zoo’

because of this i tried to created the environment with conda

when trying to add the missing packets via conda shell command or pip install the packets where not available.

Thats why i tried the environment without conda again and tried to fix by adding a R node in the flow and downloaded the missing "zoo" library. After this i got the error that the installed zoo lib is not propperly installed into the environment.

Magically after trying around the environment just worked without an error. A behavior i already came across when testing the NLP plugins. I did not install any libs, didnt change the conda installation, nothing i could mention.

But with the now working environment the "clean" skript of the forecast doesnt seem to work right.

I will add screenshots so you can see the problem:

I tried to play around with the options to parse dates, did not work

when letting it interpolate all missing hours, errors after cleaning in the model building step occured like " the data is not by hour ..."

and in the end wrote my own "clean" script, which worked with model building and inference steps, but leads to another strange behavior. Input is clean "yyyy-mm-dd HH:mm:ss" format.

Even thou i am only using model and inference, there are new values created using the same values.


Sorry, this is a long post.......thanks

0 Kudos
3 Replies
Dataiker Alumni


I recommend to recreate the underlying R code environment from the plugin page, see screenshot below:

(click on Create a new one)

Creating the code environment for the plugin yourself through Conda is not supported.

For the date parsing, you can use a "Parse date" step in a Prepare recipe to get it into the right format.

You can refer to this public project as a reference:

Hope it helps,



0 Kudos
Level 2
I recreated the environment several times. ( with and without conda)
I used the shell command provided in your handbook to set up the R environment if libs are missung.
I used the parse date step via prepare recipe. Thats where the "date_parsed " that you can see in my screenshots is coming from.
so as you can see i did the basics and it is still not working.
I could delete the whole VM, on which only DSS is running.
And try to start from scratch, but this won´t be possible in a case where a real customer is using dataiku. Therefore i would like to know how to really fix problems occuring with dataiku.
Dataiker Alumni
Hi, Unfortunately, I am not able to reproduce this issue. The fact that it was working at one point and then stopped working may indicate a problem with the R setup. Specifically, we have had feedback from users that Anaconda R introduces transient issues that are difficult to trace. From experience, the R ecosystem can be brittle at times. For the sake of simplicity, I would recommend uninstalling Anaconda R from your system, reinstall the latest R from, replaying the DSS R integration steps ( and finally rebuilding the plugin code environment.
0 Kudos


Labels (3)
A banner prompting to get Dataiku