Error running models with MLLib backend

joostjansenn Registered Posts: 7 ✭✭✭✭

Dear Dataiku Community,

Currently I am experimenting with running the built-in DataIKU models with a MLLib backend. When any of the selected features has Missing Values: Impute with average selected, it crashes with error message:

Error when computing Average on caused by: UnsupportedOperationException: empty.max.

It happens for all features, even for features without missing values. If I select the median value to impute, or a constant value it works. I have tried all the different models and custom code, but it gives the error message for all of them. Before I tried the models with sklearn on the same dataset and it all works fine.

I am running on DSS 8.0


  • MehdiH
    MehdiH Dataiker, Dataiku DSS Core Designer, Dataiku DSS Core Concepts Posts: 21 Dataiker

    Hi @joostjansenn

    To have a better understanding of your issue, we would need to take a look at the training logs. If they are likely to include sensitive data perhaps addressing it via a support ticket would be more relevant.

    The training session logs are located here: training_log.png


Setup Info
      Help me…