Resolving XGBoost Error on M3 Macs using Rosetta Translation (Homebrew , Conda , or Direct )

Options
Drushen
Drushen Registered Posts: 1

Please help I am at my wits end tried multiple strategies through terminal. Installed XGBoost, Homebrew and Conda libraries. Updated Java. The AutoMl training cannot compile output for Random Forest and XGBoost Algo's. Error documented below.

M3 Max Macbook Pro

zsh : parse error near - In terminal when doing checks

Error in DSS

Failed to train : <class 'xgboost.core.XGBoostError'> : XGBoost Library (libxgboost.dylib) could not be loaded. Likely causes: * OpenMP runtime is not installed - vcomp140.dll or libgomp-1.dll for Windows - libomp.dylib for Mac OSX - libgomp.so for Linux and other UNIX-like OSes Mac OSX users: Run `brew install libomp` to install OpenMP runtime. * You are running 32-bit Python on a 64-bit OS Error message(s): ["dlopen(/Users/drushennaidoo/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx/python37.packages/xgboost/lib/libxgboost.dylib, 0x0006): Library not loaded: /usr/local/opt/libomp/lib/libomp.dylib\n Referenced from: <4D0FF2E5-E6B5-33EC-95A4-F63DEE574377> /Users/drushennaidoo/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx/python37.packages/xgboost/lib/libxgboost.dylib\n Reason: tried: '/usr/local/opt/libomp/lib/libomp.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/opt/libomp/lib/libomp.dylib' (no such file), '/usr/local/opt/libomp/lib/libomp.dylib' (no such file), '/usr/local/lib/libomp.dylib' (mach-o file, but is an incompatible architecture (have 'arm64', need 'x86_64')), '/usr/lib/libomp.dylib' (no such file, not in dyld cache)"]

Operating system used: Mac OS 14

Answers

Setup Info
    Tags
      Help me…