Java installation error

JoshuaGohlke Partner Posts: 3 Partner

Hi all.

I previously had DI installed, but the last upgrade presented me with a java installation error. I eventually deleted the app and tried to install from scratch, but I get the same error. Unfortunately the log does not tell me much.


[2022-01-11 16:19:11.962 -0500] INFO: downloading
[2022-01-11 16:19:12.076 -0500] ERROR: java install failed
[2022-01-11 16:19:12.077 -0500] ERROR: Failed to install java

Best Answer

  • JoshuaGohlke
    JoshuaGohlke Partner Posts: 3 Partner
    Answer ✓

    I discovered a work-around to the issue. In the log, I could see that DSS installer was looking for jdk8u322-b06 even though it later tried installing a different version. When trying to download and install java, it failed with no useful error message. I could, however, download the original java package manually and place it where the installer first looked. This worked.


  • Sergey
    Sergey Dataiker, Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS Core Concepts Posts: 365 Dataiker

    Hi @JoshuaGohlke

    Can you please provide more context? What OS version are you running? Where do you see this error? Will you be able to provide <DATA_DIR>/run/install.log?

  • milhammaksum
    milhammaksum Registered Posts: 1
    Hi Sergeyd, I had the same problem, stuck on installing Java, when install free edition for windows 10. And I see the same log at java log installation. Thanks in advance.
  • JoshuaGohlke
    JoshuaGohlke Partner Posts: 3 Partner

    Hey, thanks for replying. I didn't see this until just now.

    My OS is MacOS Monterey 12.4 and I see the error on install. Specifically, the first time I use DSS it prompts me to install and then installs python and then java. That's where it fails. The install log file has the failure captured, but doesn't describe the cause. I can't find a way to run verbosely. I'm able to find the downloaded java distro and unzip it.

  • Bernard
    Bernard Registered Posts: 5 ✭✭
    edited July 10


    I have the same installation error and I'm stuck. Could you please let me know what you installed in wwich directory precisely (I'm on a Macbook pro with M2 max chip)? That would be helpful.

    Thank you


Setup Info
      Help me…