New to Dataiku DSS? Try out our NEW Quick Start Programs today and get onboarded on the product in just one hour! Let's go

installing DSS on webfaction - Java issue

Solved!
UserBird
Dataiker
Dataiker
installing DSS on webfaction - Java issue

I'm trying to install DSS on Webfaction server. After download DSS and Java and execute install script I found this error above. Can you help to me with installation?



 



[xxx@xxxx dataiku-dss-2.1.0]$ export JAVA_HOME=~/webapps/dss/jdk1.8.0_60/bin/java





[xxx@xxxx dataiku-dss-2.1.0]$ $JAVA_HOME -version

java version "1.8.0_60"

Java(TM) SE Runtime Environment (build 1.8.0_60-b27)

Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)



 



[xxx@webxxx dataiku-dss-2.1.0]$ ./installer.sh -d DATA_DIR -p 31000 -n

*********************************************

*   Dataiku Data Science Studio installer   *

*********************************************

[+] Using data directory: DATA_DIR

[*] WARNING: JAVA_HOME is defined but does not point to a suitable version of Java

[*] WARNING: Data Science Studio requires Java 7 or Java 8, 64-bit version

[*] Could not find suitable version of Java

[-] Could not find suitable Java installation. Aborting!



 

0 Kudos
1 Solution
pbertin
Dataiker
Dataiker
In your case you should define

JAVA_HOME=~/webapps/dss/jdk1.8.0_60

and the Java runtime used will be $JAVA_HOME/bin/java



Patrice Bertin

Dataiku

View solution in original post

3 Replies
pbertin
Dataiker
Dataiker
In your case you should define

JAVA_HOME=~/webapps/dss/jdk1.8.0_60

and the Java runtime used will be $JAVA_HOME/bin/java



Patrice Bertin

Dataiku

View solution in original post

UserBird
Dataiker
Dataiker
Author
like a charm 😉
0 Kudos
erivero
Level 1

Thank you very much! I had a similar problem just on my local machine. 

0 Kudos
Labels (2)
A banner prompting to get Dataiku DSS