Google Sheet Plugin error > (Test failed: cannot import name SignedJwtAssertionCredentials)

Options
UserBird
UserBird Dataiker, Alpha Tester Posts: 535 Dataiker

Hi,

I am trying to use the Google sheet plugin.

I have installed all the dependencies required in the DataScienceStudio/dss_home/bin folder

  • gspread (>=0.2.5)
  • oauth2client (>=1.5.0)
  • PyOpenSSL (>=0.15.0)
  • awesome-slugify (>=1.6.5)

but I still have the same error:

Test failed: cannot import name SignedJwtAssertionCredentials

I googled the error and I install few more package:

$ pip install pycrypto

$ pip install pyopenssl

$ pip install httplib2

$ pip install oauth2client

$ pip install ssl

But it is still not working.

I would really much appreciate you help .

Thanks

----conf info---

Mac os El Capitan 10.11.5

Tagged:

Best Answer

  • jereze
    jereze Alpha Tester, Dataiker Alumni Posts: 190 ✭✭✭✭✭✭✭✭
    Answer ✓
    Options

    Hi,

    Thanks for reporting this.

    In the list you provided, we can see that oauth2client appears twice.

    ./bin/pip install --upgrade oauth2client==1.5.2

    ./bin/pip install --upgrade oauth2client

    The second one is probably with the newest version, and there is known issue when oauth2client >= 2.0.0.

    What I suggest:

    • Delete both (./bin/pip uninstall oauth2client oauth2client==1.5.2) and install again the 1.5.2 version (./bin/pip install oauth2client==1.5.2)
    • Or, there is a beta of a new version of the plugin available that works with oauth2client >= 2.0.0. You can download the zip here. Make sure you install again the dependencies in DSS administration after installation.

    Let us know if that helps.

    Jeremy

Answers

Setup Info
    Tags
      Help me…