Java installation error on MacOs

Options
Bernard
Bernard Registered Posts: 5 ✭✭

Hello

I keep having this install error with java.
I have a MacOS (MacBook Pro 2023 M2 max chip). (This is also true on another older MacBook Pro with an intel chip by the way and an another very recent MacBook Air). DSS keeps saying that it does not find java 11.0.22.

From the drowdown menu here I choose version 12 of Sataiku but it seems to be 13 (cannot choose 13)

I specifically installed java 11.0.22 from Oracle since this one seems required

java -version

gives

java version "11.0.22" 2024-01-16 LTS
Java(TM) SE Runtime Environment 18.9 (build 11.0.22+9-LTS-219)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.22+9-LTS-219, mixed mode)
echo JAVA_HOME

Points to

/Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home

I also did

export JAVA_HOME=$(/usr/libexec/java_home -v 11)
export PATH="$JAVA_HOME/bin:$PATH"
/usr/libexec/java_home -V

Gives

Matching Java Virtual Machines (1):
11.0.22 (arm64) "Oracle Corporation" - "Java SE 11.0.22" /Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home
/Library/Java/JavaVirtualMachines/jdk-11.jdk/Contents/Home

So there is only one instance Java installed

Here is the .log file:

[2024-07-10 15:32:36.856 +0200] INFO: Starting Dataiku Launcher app version 1.3.7
[2024-07-10 15:32:37.044 +0200] INFO: App ready
[2024-07-10 15:32:37.300 +0200] INFO: Initialising config
[2024-07-10 15:32:37.301 +0200] INFO: retrieved existing config
[2024-07-10 15:32:37.312 +0200] INFO: First Dataiku Launcher start (Dataiku DSS not installed)
[2024-07-10 15:32:37.313 +0200] INFO: First install of Dataiku DSS
[2024-07-10 15:32:38.747 +0200] INFO: Confirmation granted
[2024-07-10 15:32:38.747 +0200] INFO: Install of Dataiku DSS
[2024-07-10 15:32:39.287 +0200] INFO: Getting latest Dataiku DSS info from https://cdn.downloads.dataiku.com/public/launcher/dss-latest.json
[2024-07-10 15:32:39.545 +0200] INFO: downloading https://cdn.downloads.dataiku.com/public/dss/13.0.0/dataiku-dss-13.0.0-osx.tar.gz
[2024-07-10 15:33:05.138 +0200] INFO: File downloaded to /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx.tar.gz
[2024-07-10 15:33:05.148 +0200] INFO: Deleting /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx
[2024-07-10 15:33:09.213 +0200] ERROR: Can't delete /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx
[2024-07-10 15:33:09.216 +0200] ERROR: Could not delete /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx
Error: ENOTEMPTY: directory not empty, rmdir '/Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx'
[2024-07-10 15:33:09.217 +0200] INFO: extracting /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx.tar.gz to /Users/victor/Library/DataScienceStudio/kits
[2024-07-10 15:33:21.219 +0200] INFO: Deleting /Users/victor/Library/DataScienceStudio/kits/dataiku-dss-13.0.0-osx.tar.gz
[2024-07-10 15:33:21.263 +0200] INFO: requirements for Dataiku DSS are : {"java":["11.0.22"],"python":["3.7","3.6"],"r":["3.6"]}
[2024-07-10 15:33:21.413 +0200] ERROR: Could not find version '11.0.22' for dependency 'Java'.
Error: Could not find version '11.0.22' for dependency 'Java'.
at DependencyService.getDependency (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/dependencyService.ts:22:19)
at JavaInstaller.isVersionInstalled (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dependencyInstaller.ts:96:63)
at JavaInstaller.isInstalled (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dependencyInstaller.ts:76:40)
at JavaInstaller.install (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dependencyInstaller.ts:163:42)
at MainInstaller.getRequirements (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:488:33)
at MainInstaller._doInstallDss (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:318:13)
at MainInstaller.installDss (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:90:13)
[2024-07-10 15:33:21.471 +0200] ERROR: Failed to install Java
[2024-07-10 15:33:21.471 +0200] INFO: Restoring previous install of Java
[2024-07-10 15:33:21.471 +0200] ERROR: Failed to install Java
[2024-07-10 15:33:38.149 +0200] ERROR: First Dataiku DSS install failed
[2024-07-10 15:33:38.151 +0200] ERROR: Could not find version '11.0.22' for dependency 'Java'.
Error: Could not find version '11.0.22' for dependency 'Java'.
at DependencyService.getDependency (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/dependencyService.ts:22:19)
at JavaInstaller.installVersion (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dependencyInstaller.ts:127:51)
at JavaInstaller.install (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dependencyInstaller.ts:174:24)
at MainInstaller.getRequirements (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:488:13)
at MainInstaller._doInstallDss (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:318:13)
at MainInstaller.installDss (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/main.ts:90:13)

I really don’t know what to do.

Thank you for your help

Bernard

Operating system used: MacOS

Best Answer

  • Turribeach
    Turribeach Dataiku DSS Core Designer, Neuron, Dataiku DSS Adv Designer, Registered, Neuron 2023 Posts: 1,737 Neuron
    Answer ✓
    Options

    Do note Dataiku is not supported under MacOS/Windows and it's only available for testing purposes.

    Having said that I ran Dataiku v1 on both my M2 MacBook Air and M2 Pro MacMini without any issues. I don't use the Oracle JDK as that's no longer license free. I would recommend you remove the Oracle JDK, uninstall Dataiku and try install it again. It should work then. Then you can add the Oracle JDK to your machine if you really need it. Alternatevely if you want to be in a fully supported environment you will need to use a VM.

Answers

Setup Info
    Tags
      Help me…