VS Code integration - saving recipe un-attaches output dataset

Options
clayms
clayms Registered Posts: 52 ✭✭✭✭

I have tried all manner of re-attaching the dataset and saving in the web interface on the DSS Design Node, then refreshing the VS Code. I have closed VS Code entirely, attached the dataset, saved, then re-opened VS Code.
However, in all cases as soon as I save the recipe from VS Code, the recipe un-attaches itself from the output dataset.

Where is the setting for the output dataset within the VS Code integration?


Operating system used: centos

Tagged:

Answers

  • FlorentD
    FlorentD Dataiker, Dataiku DSS Core Designer Posts: 25 Dataiker
    Options

    Hi,

    I am not sure that I understand your question correctly. If your question is related to a plugin development (recipe), I would have checked under the plugins section :

    {{name of your plugin}} -> custom-recipes > {{name of your recipe}} > recipe.json

    If your question is related to the code recipe, you should check inside your DSS instance, in the input/output section of your code recipe.

    I hope this helps.

    Best, Florent.

  • clayms
    clayms Registered Posts: 52 ✭✭✭✭
    Options

    It is about a bug in the official Dataiku VS Code extension where you can edit Dataiku recipes and plugins directly in VS Code.

    When I edit the code of a recipe in the Dataiku VS Code extension, the other settings of the recipe keep resetting themselves. There is no control over the other recipe settings from the VS Code extension, you can only edit the code. This is fine, but once I set the other recipe settings in the Dataiku web interface, those settings should not reset to anything else than what I saved them as.

    I set all the other settings on the web interface and save the recipe, then I completely log out of the Dataiku web interface. I then open up a fresh instance of VS Code, and edit the recipe code from the official Dataiku VS Code extension and save. I then close VS Code. When I then re-open the Dataiku web interface, all of the other recipe settings have been reset or completely blanked out.

    I have tried all manner and sequence of logging in one and out of the other to see if there was some conflict going on, but it always results in the same outcome.

    There is a bug in the official Dataiku VS Code extension that needs to be fixed.

Setup Info
    Tags
      Help me…