Installation of DSS failed on Ubuntu

Jānis Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 6 ✭✭✭

I tried to install DSS v11.0.2 on Ubuntu (20.04), but got an error:

[+] Creating data directory: DATA_DIR
[+] Saving installation log to /home/ubuntu/DATA_DIR/run/install.log
[+] Using Java at /usr/bin/java : openjdk version "11.0.16" 2022-07-19
[+] Checking required dependencies
+ Detected OS distribution : ubuntu 20.04
+ Checking required packages...
[+] Installation starting
[+] Initializing Python environment
[+] Initializing Python environment using platform default
+ Using default base Python for this platform : python3.7
Traceback (most recent call last):
File "/usr/lib/python3.7/", line 193, in _run_module_as_main
"__main__", mod_spec)
File "/usr/lib/python3.7/", line 85, in _run_code
exec(code, run_globals)
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/", line 168, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/", line 162, in run
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/", line 3, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/run/", line 14, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/run/plugin/", line 6, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/create/via_global_ref/builtin/", line 7, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/create/", line 15, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/discovery/", line 16, in <module>
File "/home/ubuntu/dataiku-dss-11.0.2/scripts/virtualenv.pyz/virtualenv/discovery/", line 16, in <module>
ImportError: cannot import name 'dist' from 'distutils' (/usr/lib/python3.7/distutils/
[-] Error: could not initialize Python virtualenv in /home/ubuntu/DATA_DIR/pyenv

Any help?

I tried to install DSS v10.0.8 and there were not such a problem

Operating system used: Ubuntu 20.04


Best Answer


Setup Info
      Help me…