Job failed: Error in Python process: At line 100: : ascii

clu320 Registered Posts: 3 ✭✭✭

Hi Team,

When I run the command codes inside the Dataiku jupyter notebook everything is fine. However, when I tried to run the entire code recipe and build the dataset, it shows this error message below. I am just wondering can anyone help me with this? Thank you so much!


And here is my code for those error lines:

df = pd.read_csv(i,sep = '\t',skiprows=2,engine='python',encoding='utf-8',error_bad_lines=False)
master_table = read_file(df,master_table)

Best Answer

  • RoyE
    RoyE Dataiker, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 31 Dataiker
    Answer ✓


    Can you double check that the code environment that is being used in your notebook is the same that is being used for your recipe?

    By default, recipes will default to "inherit project default" which may be based on Python 2.X which has a few extra steps that you will need to explicitly state when encoding/decoding while in Python 3.X this is by default.

    To check this setting, open the recipe's "Advanced" page and under "Python Environment", select the dropdown and select "Select an Environment" and choose the correct environment.

    Let me know if this resolves the issue.



Setup Info
      Help me…