Ready for Dataiku 10? Try out the Crash Course on new features!GET STARTED

Update Pandas version

Solved!
Leonardo
Level 2
Update Pandas version

Dear DSS,

I develop a Python recipe for my analysis which I assess first in my Pycharm lap top, before using this within DSS. Everything works fine in my Pycharm lap top, but when I try the same in DSS, I got an error which has to do with the Pandas version that is implemented in DSS.

I have DSS version 9.0.4 and I guess it should have an updated pandas version (greater than 0.25 pandas version)?  If not, could I please update the pandas version?

Thank you,

Leonardo

0 Kudos
2 Solutions
sergeyd
Dataiker
Dataiker

Hi @Leonardo 

Pandas v0.23 was originally tied to Python2.7. Since DSS8 you can use Pandas v1.0.5 for Python3.6 (and Python3.7 since DSS9): 

Screenshot 2021-11-12 at 17.01.57.png

So you will need to create Python3.6/3.7 code env to have Pandas v1.0.5. 

View solution in original post

sergeyd
Dataiker
Dataiker

@Leonardo following your question here:

https://community.dataiku.com/t5/Using-Dataiku/Updating-pandas-on-an-Automation-node/m-p/20938/highl...

Core packages are the part of the code env (Administration->Code envs). You can create code env with any set of packages and different python versions (2.7, 3.5, 3.6, 3.7). Please note that corresponding python interpreters should be installed on the DSS host machine. 

View solution in original post

3 Replies
sergeyd
Dataiker
Dataiker

Hi @Leonardo 

Pandas v0.23 was originally tied to Python2.7. Since DSS8 you can use Pandas v1.0.5 for Python3.6 (and Python3.7 since DSS9): 

Screenshot 2021-11-12 at 17.01.57.png

So you will need to create Python3.6/3.7 code env to have Pandas v1.0.5. 

View solution in original post

sergeyd
Dataiker
Dataiker

@Leonardo following your question here:

https://community.dataiku.com/t5/Using-Dataiku/Updating-pandas-on-an-Automation-node/m-p/20938/highl...

Core packages are the part of the code env (Administration->Code envs). You can create code env with any set of packages and different python versions (2.7, 3.5, 3.6, 3.7). Please note that corresponding python interpreters should be installed on the DSS host machine. 

View solution in original post

Leonardo
Level 2
Author

Hi @sergeyd ,

Thank you very much, I will try these options. It look that I can't create code envs in this DSS server and I may have to ask our IT how to do this, but I will give a try for sure. 

Thank you again!

Leonardo

A banner prompting to get Dataiku DSS