You now have until September 15th to submit your use case or success story to the 2022 Dataiku Frontrunner Awards!ENTER YOUR SUBMISSION

Unwanted time zone conversion in join recipe (Redshift)

Solved!
Filip_Pejsa
Level 1
Unwanted time zone conversion in join recipe (Redshift)

When I use Join recipe to join two Redshift tables in DSS, it automatically applies time zone conversion to date field:SQL tz conversions.png

You can set up the time zone for the dataset in its setting, but the conversion stays there even thought it actually does nothing. image.png

Is there a setting that suppresses (removes) the conversion altogether ?


Operating system used: Windows 10

1 Solution
fchataigner2
Dataiker
Dataiker

Hi,

unless the column in the input table is typed as a timestamp, there's no way to avoid the conversion. We'll look into suppressing when both origin and destination timezones are UTC.

View solution in original post

0 Kudos
1 Reply
fchataigner2
Dataiker
Dataiker

Hi,

unless the column in the input table is typed as a timestamp, there's no way to avoid the conversion. We'll look into suppressing when both origin and destination timezones are UTC.

0 Kudos

Labels

?
Labels (2)
A banner prompting to get Dataiku