Discover all of the brand-new features and improvements to existing capabilities in the Dataiku 11.3 updateLET'S GO

Unable to install FBProphet - Python env 36

zackemcee
Level 1
Unable to install FBProphet - Python env 36

Hello all,

I'm trying to install FBProphet on a DSS environment but I can't seem to get it to work.

You'll find in the attachments the diagnostic of the environment, as well as the logs when trying to install the FBProphet package.

Thank you!

0 Kudos
3 Replies
CatalinaS
Dataiker

 Hi @zackemcee 

Based on the below logs it seems you are running into the same issue as discussed in this community article Errors when installing Facebook Prophet.

  ERROR: Failed building wheel for fbprophet
    ERROR: Command errored out with exit status 1:
...
creating build/lib/fbprophet
creating build/lib/fbprophet/stan_model
INFO:pystan:COMPILING THE C++ CODE FOR MODEL anon_model_dfdaf2b8ece8a02eb11f050ec701c0ec NOW. error: command 'gcc' failed with exit status 1

 

Have you tried the solution mentioned there?

 

0 Kudos
zackemcee
Level 1
Author

Hello,

Thank you for the reply. 

I tried downgrading the pystan to the version mentioned in the solution. However, I do not know how to install and activate the SCL devtoolset package... I have no idea how to add that line

source /opt/rh/devtoolset-8/enable

Care to elaborate on the steps please ?

Thank you once again!

0 Kudos
CatalinaS
Dataiker

Hi @zackemcee,

 

Downgrading the pystan version should be sufficient to fix the issue without using SCL devtoolset. Are you getting the same error? If the error is different please share it. You could also open a support ticket on support.dataiku.com with the new code env diagnostic. 

Installing and activating the SCL devtoolset package requires access to the instance where DSS is running. You need to connect by SSH to the instance and run the CLI command. If you don't have access to the instance you need to ask your sysadmin.

0 Kudos