Discover all of the brand-new features and improvements to existing capabilities in the Dataiku 11.3 updateLET'S GO

M1 libraries

Solved!
Erlebacher
Level 4
M1 libraries

Dataiku does not run natively on the M1 Mac. But I am wondering if my library code can use libraries compiled for the M1 chip while the Dataiku framework continues to run on the Intel Chip through Rosetta. Thanks.


Operating system used: Mac Ventur

1 Solution
AlexandreV
Dataiker

Hello @Erlebacher,
You are right, DSS does not natively run on M1 and needs to leverage Rosetta.Python Library code written in the Library Editor is code that will be reusable within your project. This means that it will inherit the packages installed in the code-env (or base DSS env) that runs it.
Dataiku DSS does not support code envs running with ARM (M1) built Python binaries.
On x86 (Intel) based code envs you will not be able to run a native ARM (M1) package.
I would strongly suggest only using x86 (Intel) based packages.

Alex

View solution in original post

0 Kudos
1 Reply
AlexandreV
Dataiker

Hello @Erlebacher,
You are right, DSS does not natively run on M1 and needs to leverage Rosetta.Python Library code written in the Library Editor is code that will be reusable within your project. This means that it will inherit the packages installed in the code-env (or base DSS env) that runs it.
Dataiku DSS does not support code envs running with ARM (M1) built Python binaries.
On x86 (Intel) based code envs you will not be able to run a native ARM (M1) package.
I would strongly suggest only using x86 (Intel) based packages.

Alex

0 Kudos