Announcing the winners & finalists of the Dataiku Frontrunner Awards 2021! Read their inspiring stories

Is there a work-around for updating Pandas for use in a python code environment?

Solved!
Graham_E
Level 2
Is there a work-around for updating Pandas for use in a python code environment?
I'm working on something that would benefit greatly from using a newer version of pandas. I am aware that pandas is fixed to version 0.20.3 because that is the version the dataiku module requires. I have also experimented with overriding the core modules. I can work with the newest version of pandas by doing this but the dataiku module throws an error (of course). Ideally, my scripts would be able to use both the newest pandas version and the dataiku module. Is this a no win scenario? Is it possible to build data science studio in a way that makes use of a newer version of pandas?

Thanks
1 Solution
Clément_Stenac
Dataiker
Dataiker

Hi,

Upgrade of pandas 0.20 to 0.23 happened in DSS 5.1.0, released in January 2019, it's likely that you are still using an older version of Dataiku.

Your company will need to upgrade to a more recent version of Dataiku to get pandas 0.23

View solution in original post

8 Replies
Clément_Stenac
Dataiker
Dataiker
Hi,

It is not currently possible. We plan on updating pandas pretty soon, and/or to make it possible to relax this constraint
0 Kudos
Automater
Level 1

Is this still planned for an update to DataIKU? I am also interested in using a newer version of Pandas even if it is not the most up to date version. Right now whenever I switch between environments (desktop local to Data IKU) I have to spend at least an hour troubleshooting error thrown because of the version)

0 Kudos
CoreyS
Community Manager
Community Manager

We can confirm that we did update Pandas in 2018. We are currently looking into the next update. I hope this helps!

Looking for more resources to help you use Dataiku effectively and upskill your knowledge? Check out these great resources: Dataiku Academy | Documentation | Knowledge Base

A reply answered your question? Mark as ‘Accepted Solution’ to help others like you!
0 Kudos
Automater
Level 1

I have an instance of DataIKU that is using python 3.6 but the version of pandas it displays in my code environment is pandas 0.20.3

Which is why I was wondering how others have a higher version? Or if that must have been configured by the on-boarding team at my company. (Though I am not sure why we would do this)

0 Kudos
Clément_Stenac
Dataiker
Dataiker

Hi,

Upgrade of pandas 0.20 to 0.23 happened in DSS 5.1.0, released in January 2019, it's likely that you are still using an older version of Dataiku.

Your company will need to upgrade to a more recent version of Dataiku to get pandas 0.23

View solution in original post

rona
Level 3

In our DSS design instance (version 6.0.4), we have a code environment for python 3.6 with pandas version 0.23.4.

Please, could you confirm if there is a way today to update this pandas version ?

Annie

0 Kudos
Clément_Stenac
Dataiker
Dataiker

Hi,

It is not currently possible to update pandas. We are working on this.

0 Kudos
rona
Level 3

Hello,

Please, when can we expect this possibility ?

Annie

Labels (2)
A banner prompting to get Dataiku DSS