Join us, on May 27th, for an introduction to the new Dataiku Academy Learn more

Can recipe run on python 3.x?

Level 2
Can recipe run on python 3.x?

Hi, 

I created a custom recipe to run on dss6 and noted an error while it was running on a python 3.6 code env.

Begin python stack

Traceback

File /mnt/somepath/.../custom-python-recipe/pyoutblahblahblah/python-exec-wrapper.py, line 194, in <module> 

exec(f.read())

file"<string>", line 82, in <module>

typeerror:'map' object is not subsciptable

end python stack.

I don't have any codes in the codes of stated in the trace and let me to believe its one of the dataiku core codes. The error also suggest that this is due to the python2 vs python3 difference. Please advise on this.

 

Thank you.

0 Kudos
1 Reply
Dataiker
Dataiker

Hi @jax79sg ,

As you pointed out, this python error suggests you are using Python2 syntax with Python3. Make sure your libraires are Python3 compatible.

A closer look at your code would be helpful to help you.

Damien Jacquemart, Lead Data Scientist @Dataiku
0 Kudos
Labels (2)