Survey banner
The Dataiku Community is moving to a new home! New posts are now disabled and the community will shortly be in temporary read only mode: LEARN MORE

Node ID for govern

Mikhivin
Level 1
Node ID for govern

Hi everone.

 

I've come across a problem concerning connection of my designer node to a govern instance.

In tutorials I've read that it's binding to set up a correct NodeId for an instance to be connected to govern.

But the thing is that I can't find any NodeID in the designer instance (see screenshot).

 

Also I failed to find proper guidance on this topic.

Would be very glad to receive help.

 

Thanks.


Operating system used: MacOs 13.1

0 Kudos
5 Replies
AlexT
Dataiker

Hi @Mikhivin ,
You've installed DSS on MacOS with the Launcher most likely in this case the node id is not set in install.ini this is done automatically for a Fleet Manager-managed instance or if you pass the argument when installing DSS. 

 

  • ~/Library/DataScienceStudio/dss_home/bin/dss stop
    
  • Edit the install.ini file If this was not done you can just edit ~/Library/DataScienceStudio/dss_home/install.ini in the general section node-id = some_value. 

    Screenshot 2023-03-09 at 12.10.32.png 

    ~/Library/DataScienceStudio/dss_home/bin/dssadmin regenerate-config
    
  • Start DSS

    ~/Library/DataScienceStudio/dss_home/bin/dss start
    



0 Kudos
Mikhivin
Level 1
Author

Hi, @AlexT 

 

Thank you for the answer.

 

I did as you wrote but still has nothing in Govern section,Test Dataiku Govern integration failed: 

 

Dataiku Govern Instance is unreachable

The Dataiku Govern instance is unreachable, please try again later or check your configuration settings

 

Could you please tell what could be an issue here?

 

Thank you.

0 Kudos
AlexT
Dataiker

Hi,
Can you please share a screenshot of your configuration settings? 
Also, is the govern node running? Did you install it on MacOS as well? This is an unusual setup for Govern node and likely untested. We recommend setting up DSS/Govern node on Linux VM or CloudStacks. 

Thanks


0 Kudos
Mikhivin
Level 1
Author

Hi @AlexT 

 

Attached are the configuration I have

0 Kudos
MatiasL
Dataiker

Hi @Mikhivin ,

Could you please change the value 'nodeid' in the install.ini (Design Node) as attached? It should be 'mydesign'

 

After doing this modification, please proceed on restarting the DSS Service (Design node)

  • ~/Library/DataScienceStudio/dss_home/bin/dss restart
    

Also just to confirm, did you setup a PostgreSQL db on it? Services of the db and of the govern node are started as well?

If so, please retry the connection and let me know the results.

Just tested from scratch on my environment and the connection seems to be working as attached.

 

Looking forward to your feedback

0 Kudos