Survey banner
Share your feedback on the Dataiku documentation with this 5 min survey. Thanks! TAKE THE SURVEY

Time Series Forecasting- Code Environment Setup Problem for Required Packages Gluonts, Mxnet

raphanash
Level 2
Time Series Forecasting- Code Environment Setup Problem for Required Packages Gluonts, Mxnet

Hi there,

I am using the Forecasting Plugin to train a forecasting model for a time series commodities dataset. 

However, I have a few issues with regards to setting up a functional code environment for this plugin. In particular, DSS tells me that I need gluonts and mxnet in my environment in order to start the training process. 

Therefore I tried adding mxnet-cu100==1.7.0 and gluonts==0.10.4 in the general >> extra options settings of the plugin managed environment but I received this errror:

flow_errormessage.png

I also created a new python environment and added the set of packages for forecasting in "packages to install". This worked with gluonts and mxnet now included in the environment.

However, when I now try and dissociate the previous environment in the plugin page, I cannot see this new python environment in the dropdown list (the only ones available are those created and managed by DSS.)

DSS_error_forecastingplugin.png

Many thanks for any advice. 

 

0 Kudos
4 Replies
CatalinaS
Dataiker

Hi @raphanash 

You cannot see your new code environment in the dropdown list because plugins cannot use manually created code environments. They can only use the plugin managed code environments that are created by the plugin requirements.

To update the libraries used by a plugin you have to convert the plugin to a dev plugin and update the python packages manually in the requirements.txt file and then rebuild the environment.

Please note that starting with DSS version 11 Time Series Forecast plugin is deprecated and you should consider using native time series forecasting features.

0 Kudos
raphanash
Level 2
Author

Hi,

Thank you for your response. I have followed your advice, created a dev plugin and uploaded a requirements.txt file containing all the necessary packages.


However, once I click "save and update", I receive this error again:

image (9).png

DSS hasn't been able to upload the mxnet package- which is strange because I can download mxnet on my system successfully. 

0 Kudos
raphanash
Level 2
Author

I am using the "Forecast (GPU - CUDA 100)" plugin, is this the native one? If not let me know which plugin I should use. 

Many thanks!

 

0 Kudos
CatalinaS
Dataiker

The native time series forecasting feature is available in DSS11 in the Lab section - Visual ML -Time Series Forecasting.

0 Kudos

Labels

?
Labels (2)
A banner prompting to get Dataiku