Announcing the winners & finalists of the Dataiku Frontrunner Awards 2021! Read their inspiring stories

Steps required to install Python latest version 3.9 on Dataiku DSS

Solved!
Ankur30
Level 1
Level 1
Steps required to install Python latest version 3.9 on Dataiku DSS

Hi

 

Please let me know all the steps required to install python latest version i.e. 3.9.6 in Dataiku DSS version 9.0.3.

It is required on urgent basis.

 

Thanks in advance,

Ankur.

0 Kudos
1 Solution
JuanE
Dataiker
Dataiker

Hello Ankur,

Please note that Python 3.9 is not supported in DSS at the moment. The currently supported versions of Python are 2.7, 3.5, 3.6 and 3.7. There are more details on how to create and manage Python code environments here:

https://doc.dataiku.com/dss/latest/code-envs/operations-python.html

Best regards,

Juan Eiros Zamora

View solution in original post

0 Kudos
4 Replies
JuanE
Dataiker
Dataiker

Hello Ankur,

Please note that Python 3.9 is not supported in DSS at the moment. The currently supported versions of Python are 2.7, 3.5, 3.6 and 3.7. There are more details on how to create and manage Python code environments here:

https://doc.dataiku.com/dss/latest/code-envs/operations-python.html

Best regards,

Juan Eiros Zamora

View solution in original post

0 Kudos
Ankur30
Level 1
Level 1
Author

Hi @JuanE ,

is there way we can install python 3.9 in Dataiku, because in our current project coding is done in python 3.9 version.

Best regards,

Ankur

0 Kudos
HarizoR
Dataiker
Dataiker

Hi Ankur30,

As mentioned by @JuanE it is not possible to run Python 3.9 code in Dataiku DSS as of today. 

Do you have specific parts of your code which aren't backward-compatible with Python 3.7 ? If so, we would be interested to know more about which features of 3.8/3.9 they leverage. Supporting more recent versions of Python 3.x is already in our backlog, and getting a better view of how they are used in the field will definitely help prioritising future product improvements.

Best,

Harizo

0 Kudos
Ankur30
Level 1
Level 1
Author

Thank you @HarizoR  and @JuanE for your response.

Sure, I will check and let you what are those specific constructs that are written in python 3.9 and if there is anyway for us to make it compatible with python 3.7.

Thank you

Ankur.

0 Kudos
Labels (4)
A banner prompting to get Dataiku DSS