Ready for Dataiku 9? Try out the Crash Course on new features! GET STARTED

Plugin Python Code environment error - Pandas Version conflict

Solved!
NN
Level 3
Plugin Python Code environment error - Pandas Version conflict

Hi,

I am trying to create a plugin managed python environment for a custom recipe.

The problem i face is that while setting up the environment i get the error 

Updating code environment according to spec 
...
Installing from Pip requirementsERROR:
Cannot install pandas<1.1 and >=1.0 and pandas==0.23.4 because these package versions have conflicting dependencies.
ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependenciesThe conflict is caused by:
The user requested pandas<1.1 and >=1.0

The user requested pandas==0.23.4
To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

But when we create a DESIGN_MANAGED python code environment with similar settings there doesnt seem to be a conflict there.

Can someone help if they have faced a similar issue ?

Some additional details have been shared below.

Dataiku version - 8.0.1

dataiku environment - Python36 / Managed by DSS / No containers

desc.json ->

{
"acceptedPythonInterpreters": ["PYTHON36"],
"forceConda": false,
"installCorePackages": true,
"installJupyterSupport": false
}

Requirements.txt ->

pandas>=1.0,<1.1

 

0 Kudos
1 Solution
Ignacio_Toledo

Hi @NN,

I just made a test and this worked for me: just add a new entry to the desc.json like this:

{
"acceptedPythonInterpreters": ["PYTHON36"],
"forceConda": false,
"installCorePackages": true,
"corePackagesSet": "PANDAS10",
"installJupyterSupport": false
}

After regenerating the plugin code environment there were no problems with using pandas 1.

Hope this helps! 

View solution in original post

2 Replies
Ignacio_Toledo

Hi @NN,

I just made a test and this worked for me: just add a new entry to the desc.json like this:

{
"acceptedPythonInterpreters": ["PYTHON36"],
"forceConda": false,
"installCorePackages": true,
"corePackagesSet": "PANDAS10",
"installJupyterSupport": false
}

After regenerating the plugin code environment there were no problems with using pandas 1.

Hope this helps! 

View solution in original post

NN
Level 3
Author

That Worked perfectly Thanks a lot.

0 Kudos
A banner prompting to get Dataiku DSS