'Dataiku-info'module couldn't be found

JazzminnNo Registered Posts: 6 ✭✭✭

A dataiku project, which uses a code recipe from a plugin, migrated from our prod environment to a plugin development environment along with the used plugin. With the project code and plugin code untouched, using the same code environment, an error is shown saying that the 'dataiku-info'-module couldn't be found (see uploaded image: 'dataiku_info.png'). You can also refer to 'module-error.png'.

I included the python code in a .txt file from the plugin where the error is occurring. Mind you that this code was not changed and worked fine on the prod environment.

What are we doing wrong here?

Thanks in advance,


Operating system used: RedHat

Best Answer

  • Alexandru
    Alexandru Dataiker, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 1,209 Dataiker
    Answer ✓


    dataiku_info is a custom library that was present in your old instance. This could have been included in the global project libraries for example which were not moved over.

    To confirm I would suggest the working environment in a Notebook you perform :

    from dataiku_info import dataset_info


    This should print out the location of dataiku_info.



  • JazzminnNo
    JazzminnNo Registered Posts: 6 ✭✭✭

    Hi Alex,

    Thank you for the explanation, makes sense. Meanwhile the problem temporarily is worked around by maintaining the scripts of the library locally, but in near future it will probably be pointing to a global project library again.

Setup Info
      Help me…