text visualization でwordcludを使用した際のエラー

Options
Koji
Koji Dataiku DSS Core Designer, Registered Posts: 12 ✭✭✭

text visualizationのwordcloudを使用しようとした際に、添付画像のようなpythonに関するエラーが出てします。

対処方法などありますでしょうか。

Comments

  • Tsuyoshi
    Tsuyoshi Dataiker, PartnerAdmin, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 75 Dataiker
    Options

    Dataikuコミュニティのシステム移行が完了して、回答を投稿できるようになりましたので、Data Haikerコミュニティで回答した内容をこちらにも記載しておきます。

    ——-
    プラグインが作成するCode EnvのPythonバージョンによっては、依存パッケージに「pillow==10.3.0」が含まれるため、こちらのURLなどで報告されている事象が発生することが原因となります。

    「Text Visualization」プラグインの今後のサポート方針については、別途確認したいと思いますが、取り急ぎの回避策を以下にご連絡します。

    プラグインが利用するCode EnvをいったんDISSOCIATEし、Code Envを再作成します。その際にPythonのバージョンとして「3.8 以下」のモジュールを指定することで、「pillow==10.3.0」ではなくて「Pillow==9.5.0」が利用されるため、エラーの回避が可能となります。

  • Tsuyoshi
    Tsuyoshi Dataiker, PartnerAdmin, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 75 Dataiker
    Options

    アップデート情報がありましたので、こちらでご連絡します。

    Text Visualizationプラグインについて、先日(2024-07-02 )新しいバージョン(1.1.1)がリリースされて、上記の不具合は解消されたようです。今後は、新バージョンをご利用いただけますので、どうぞよろしくお願いいたします。

  • Koji
    Koji Dataiku DSS Core Designer, Registered Posts: 12 ✭✭✭
    Options
Setup Info
    Tags
      Help me…