failed to execute time series plugin on GKE

Options
YasserMohsen
YasserMohsen Registered Posts: 3 ✭✭✭✭

I have a time series plugin which I run with no problem on DSS backend, but while changing the container configuration of the time series recipe to run on GKE, I get the following error:

pull access denied for dku-exec-base-z2f6i7kx3do8zemd2dcjs0dl, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

After checking the documentation, I have tried to change the containerized execution in "plugin_timeseries-preparation_managed" Code Env to be built with all containers configurations, I got the following error:

ERR_CODEENV_CONTAINER_IMAGE_FAILED
Job failed: No recorded container image tag for this code environment: in act.compute_crmdb_1m_NP: No recorded image tag for env PYTHON plugin_timeseries-preparation_managed version= null. Maybe you need to build Docker image

Also, it seems that it is building through python 2.7, although there is a python 3.6 env configured that it should be working fine.

Can someone help me with this issue?

Answers

Setup Info
    Tags
      Help me…