failed to execute time series plugin on GKE

YasserMohsen
YasserMohsen Registered Posts: 3 ✭✭✭✭

I have a time series plugin which I run with no problem on DSS backend, but while changing the container configuration of the time series recipe to run on GKE, I get the following error:

pull access denied for dku-exec-base-z2f6i7kx3do8zemd2dcjs0dl, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

After checking the documentation, I have tried to change the containerized execution in "plugin_timeseries-preparation_managed" Code Env to be built with all containers configurations, I got the following error:

ERR_CODEENV_CONTAINER_IMAGE_FAILED
Job failed: No recorded container image tag for this code environment: in act.compute_crmdb_1m_NP: No recorded image tag for env PYTHON plugin_timeseries-preparation_managed version= null. Maybe you need to build Docker image

Also, it seems that it is building through python 2.7, although there is a python 3.6 env configured that it should be working fine.

Can someone help me with this issue?

Answers

  • Clément_Stenac
    Clément_Stenac Dataiker, Dataiku DSS Core Designer, Registered, Moderator Posts: 754 Dataiker

    Hi,

    It seems that you have not built the base Docker image (upon which per-code-env images will be built). Instructions for this can be found here: https://doc.dataiku.com/dss/6.0/containers/setup-k8s.html#build-the-base-image

  • YasserMohsen
    YasserMohsen Registered Posts: 3 ✭✭✭✭

    Thanks for your support and your prompt reply.


    I have the base image built before, but should I re-build it if I have changed the containerized execution settings of this Code Env? If yes, I have tested re-building the image and I was shocked that it failed with the error:

    """

    Cannot find a valid baseurl for repo: base/7/x86_64
    Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=container error was
    14: curl#7 - "Failed to connect to 2001:1b48:203::4:10: Network is unreachable"

    """

    It is weird as we don't have network connection issue and we have build it before with no errors. Also, I have re-set the containerized executions of this Code Env, but it failed too.

  • Clément_Stenac
    Clément_Stenac Dataiker, Dataiku DSS Core Designer, Registered, Moderator Posts: 754 Dataiker

    Hi,

    It definitely looks like you do have some connection issues, at least for IPv6 from the containers

    You may want to check whether you can reach this hostname from the host machine, both in IPv4 and IPv6 and then try from within a bash-running container.

Setup Info
    Tags
      Help me…