Python Environment will not build

Options
Citizen001
Citizen001 Registered Posts: 1
edited July 16 in Using Dataiku
"The Protobuf compiler, `protoc`, which is required for"      RuntimeError: The Protobuf compiler, `protoc`, which is required for building this package, could not be found.Failed to build pycld3Installing collected packages: sklearn-crfsuite, pycld3, packaging, murmurhash, langid, joblib, catalogue, blis, backports.zoneinfo, scikit-learn, pythainlp, preshed, fastcore, thinc, pyvi, spacy  Running setup.py install for pycld3: started  Running setup.py install for pycld3: finished with status 'error'      See https://github.com/protocolbuffers/protobuf for information on installing Protobuf.      [end of output]    note: This error originates from a subprocess, and is likely not a problem with pip.error: legacy-install-failure× Encountered error while trying to install package.╰─> pycld3note: This is an issue with the package mentioned above, not pip.hint: See above for output from the failure.[notice] A new release of pip available: 22.3.1 -> 24.0[notice] To update, run: C:\Users\<removed>\AppData\Local\Dataiku\DataScienceStudio\dss_home\code-envs\python\plugin_nlp-preparation_managed\Scripts\python.exe -m pip install --upgrade pip

Note: attempted to install protoc from github, but Windows Defender blocks the install.

Answers

Setup Info
    Tags
      Help me…