When trying to execute a SQL recipe we have the error SHOWPLAN permission denied in database

Options
DataIKUAD
DataIKUAD Dataiku DSS Core Designer, Registered Posts: 1
edited July 16 in Using Dataiku

When trying to execute a SQL recipe in a dataiku flow, we have the error SHOWPLAN permission denied in database. We tried to set the advanced options for the SQL recipe to not display the execution plan. We tried to uncheck the validation before the run.

Are there any other settings we need to modify to disable the SHOWPLAN for SQL recipes?

The error we have in the logs is

[2024/02/01-15:26:24.590] [FRT-43-FlowRunnable] [INFO] [dku.queries.executionplan] - Compute execution plan
[2024/02/01-15:26:24.593] [FRT-43-FlowRunnable] [WARN] [dku.queries.executionplan] - Computing execution plan inside a transaction
[2024/02/01-15:26:24.670] [FRT-43-FlowRunnable] [WARN] [dku.flow.sql] - Could not print execution plan
com.microsoft.sqlserver.jdbc.SQLServerException: SHOWPLAN permission denied in database 'xxxxxxxx'.
 at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:255)
 at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1695)
 at com.microsoft.sqlserver.jdbc.SQLServerStatement.doExecuteStatement(SQLServerStatement.java:920)
 at com.microsoft.sqlserver.jdbc.SQLServerStatement$StmtExecCmd.doExecute(SQLServerStatement.java:814)
 at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:7675)
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:4137)

Answers

Setup Info
    Tags
      Help me…