RMarkdown: pandoc version issue

Options
aad34210
aad34210 Partner, Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS ML Practitioner, Dataiku DSS Core Concepts, Registered Posts: 25 Partner

Hi, everyone.

I faced error when "FORCE BUILD" button on "Rmarkdown report" clicked.

Error message shows following.

Would you please help me how to solve this issues?

It seems that pandoc need to be update but I couldn't find out how to update pandoc in this environment...

This environment is running on AWS EC2 server (Amazon Linux AMI release 2018.03).



Best regards.

Thank you.

Tagged:

Answers

  • aad34210
    aad34210 Partner, Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS ML Practitioner, Dataiku DSS Core Concepts, Registered Posts: 25 Partner
    Options

    I resolved this question myself in following way.

    For person who facing same issue I explain how to resolve this issue.

    ====

    Environment: AWS EC2 Amazon Linux 2018.3



    1. Install stack (Haskell based)

    https://docs.haskellstack.org/en/stable/install_and_upgrade/#linux

    2. Download pandoc from source code.

    3. Compiling from pandoc source code.

    https://pandoc.org/installing.html#compiling-from-source



    *Note*

    Sample code in above documents.

    ====



    Best regards.

    Thank you.

  • tgb417
    tgb417 Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS ML Practitioner, Dataiku DSS Core Concepts, Neuron 2020, Neuron, Registered, Dataiku Frontrunner Awards 2021 Finalist, Neuron 2021, Neuron 2022, Frontrunner 2022 Finalist, Frontrunner 2022 Winner, Dataiku Frontrunner Awards 2021 Participant, Frontrunner 2022 Participant, Neuron 2023 Posts: 1,595 Neuron
    Options

    Has anyone figured out how to get rmarkdown working on Macintosh? I see that pandoc is required. However, because I'm on a Macintosh I'm not clear what is the best way to install this.

    --Tom

Setup Info
    Tags
      Help me…