Dataiku custom webapp example not found

ihb Partner, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 7 Partner


I tried following the example plugin from a webapp from the dataiku website

The webapp itself works fine, but when I try to use the plugin, the webapp doesn't show anything despite the logs saying that the webapp started. The webapp also doesn't show up in the project webapp list and when I refresh the page, the error that the webapp does not exists. I have also tried multiple types of deployments and none worked.


Backend log:

/home/dataiku/dataiku-dss-11.1.1/python36.packages/tornado/ DeprecationWarning: @return_future is deprecated, use coroutines instead  DeprecationWarning)2023-01-20 14:37:11,182 INFO use old-style cookie sniffing handler2023-01-20 14:37:11,184 INFO Starting Bokeh server version 0.12.16 (running on Tornado 5.1.1)2023-01-20 14:37:11,187 WARNING Host wildcard '*' will allow connections originating from multiple (or possibly all) hostnames or IPs. Use non-wildcard values to restrict access explicitly2023-01-20 14:37:11,189 INFO Bokeh app running at: http://localhost:35345/backend2023-01-20 14:37:11,216 INFO 200 GET /static/js/bokeh.min.js ( 5.95ms

Is there something that I am missing or an instance setting that could cause this? I have administrator access to this instance.

Operating system used: Linux

Best Answer

  • ihb
    ihb Partner, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 7 Partner
    Answer ✓

    After doing some tests, the issue seems to occur when the plugin is given roles, AND webapp inputs are given through the webapp config. The workaround for this is to either remove the webapp inputs configs and hardcode the column names, or to remove the roles from the webapp.

    It seems that the config editing functionality of the role based webapp has been removed but the interface for it is still there. The tutorial linked above also seems to be out of date.


  • Sarina
    Sarina Dataiker, Dataiku DSS Core Designer, Dataiku DSS Adv Designer Posts: 315 Dataiker

    Hi @ihb

    I can reproduce the issue if there is some type of issue with my plugin code. And indeed I notice that if I restart the webapp backend, I'm no longer able to retrieve the logs indicating what the error is!

    Can you try the following in order to troubleshoot this?
    (1) Create a brand new version of the plugin webapp
    (2) Before selecting any parameters or restarting the webapp backend, click on the "Backend logs" tab, click on the "refresh button" and copy the full contents of the log file:

    Screen Shot 2023-01-25 at 4.45.01 PM.png

    If you still don't see any additional errors displayed here, we can also try out the plugin itself. To do that, you can click on Actions > Download this plugin and attach it here for testing.

    Screen Shot 2023-01-25 at 4.53.32 PM.png

    I also think that the plugin webapp should indeed more clearly show any errors, and will pass along this feedback to our product team for further review.


Setup Info
      Help me…