Missing data in parsed date column

Options
Aminmin
Aminmin Dataiku DSS Core Designer, Registered Posts: 18 ✭✭✭✭

hi, i uploaded a file that has a date column in YYYY-MM-DD with meaning as date(unparsed). I parsed the column and now has a YYYY-MM-DD followed by timezone. When i run the script, the output file has missing dates from both date and parsed_date columns. Datatype was also changed.

Pls help to identify what steps i may have missed.

Again, if i change datatype to date and left the date(unparsed), i run successfully with warning and again the data disappeared.

Pls help. I thank you in advance


Operating system used: Windows10

Tagged:

Answers

  • Alexandru
    Alexandru Dataiker, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 1,209 Dataiker
    Options

    Hi,

    Can you confirm what dataset type(SQL, Cloud Storage, etc) you have?

    Are you using append mode?

    Can you try to clear the datasets and try building the output dataset (forced recursive build) to ensure all datasets upstream are fully built as well?

    Thanks,

  • Aminmin
    Aminmin Dataiku DSS Core Designer, Registered Posts: 18 ✭✭✭✭
    Options

    Dear AlexT, thank you for your kind advise.

    I managed to resolve the issue by letting the datatype be string.

    Regards

Setup Info
    Tags
      Help me…