R notebook - impossible to import 'dataiku'

UserBird Dataiker, Alpha Tester Posts: 535 Dataiker

I have issues to get DSS working with anaconda and R notebooks on a mac.

The problem started because after successful completion (no errors) of the steps described in the documentation to have R running in DSS, it is impossible to load the dataiku package.

I tried to install DSS from the dmg archive, the installation runs smoothely but in the end, impossible to get R notebooks working properly.

I tried to install DSS from the source specifying the -C (install with conda environment) :

./installer.sh -d $DSS_PATH/dss_home -p 11200 -C [16:44:22]
* Dataiku DSS installer *
[+] Creating data directory: /Users/mkoutero/Library/DataScienceStudio/dss_home
[+] Saving installation log to /Users/mkoutero/Library/DataScienceStudio/dss_home/run/install.log
[+] Using Java at /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java : java version "1.8.0_121"
[+] Using conda Python
[+] Checking required dependencies
+ Detected OS distribution : osx 10.12
+ Checking required packages...
[+] Installation starting
[+] Initializing Conda environment
Fetching package metadata .............

PackageNotFoundError: Package missing in current osx-64 channels:
- dataiku_dss 20170125 py27_0

But if I run it without the -C flags, it works.

So I would say that there is something wrong with getting the dataiku python and/or R packages properly installed with anaconda and mac os. Other R packages are just fine and easily imported when running R notebook.

How to resolve this ?

Many thanks for any input.

PS : I also tried with an R install from cran and within anaconda framework. no change.


  • mkoutero
    mkoutero Registered Posts: 2 ✭✭✭✭
    Ok, I found out what went wrong.

    I did not notice immediately that sources specific for mac existed, a fresh install from them with the -C flag made it.

    I still had to export/import the projects manually as the tutorial to transfer/upgrade dss_home did not work in this situation (it kept regular python libraries and not the ones from anaconda).
Setup Info
      Help me…