plugin not appearing in flow view

UserBird Dataiker, Alpha Tester Posts: 535 Dataiker

I developped a plugin that takes datasets as inputs.

I uploaded it via the 'Advanced' option i.e. by uploading a zip.

I can see my plugin in the plugin list but it does not appear when I click on a dataset in the Flow view.

And when I go to the Installed Plugin tab the right column is empty (there should be something like (Recipe: take a dataset and do...).

Do you have any idea what might be causing this ?

Thank you for your help !


  • Clément_Stenac
    Clément_Stenac Dataiker, Dataiku DSS Core Designer Posts: 753 Dataiker
    Does your plugin appear in the "New recipe" menu ?

    * If it does, then to make it also appear in the dataset actions, you need to add in the recipe.json file a line like:
    "selectableFromDataset": "main",
    Where "main" must be replaced by the name of the input role in which the "current" dataset will go

    * If it does not, then it means your plugin does not work properly, probably because of a parsing error somewhere. In the dev section, do you see warnings about components not loaded ? You can also check the backend.log file for errors loading that plugin
  • UserBird
    UserBird Dataiker, Alpha Tester Posts: 535 Dataiker
    Thanks for your answer !
    The recipe.json had the "selectable from dataset" line and the plugin worked properly.
    The issue was that the folder in which I had the and recipe.json files (let's call it the 'recipe folder') had the same name as another 'recipe folder' from another plugin...

    I changed the name and solved the issue.
Setup Info
      Help me…