Pivot is clearing all other column

UserBird Dataiker, Alpha Tester Posts: 535 Dataiker

I am trying to do a pivot on a dataset and everything is working except that all the column not used in the pivot are cleared. In the recipe itself it work but when I run it, all columns are blank. I tried to put other colomns to "keep if constant", "make an array" and even "keep first value" but it's still the same.

PS : my dataset is sorted.

Any idea?



  • AdrienL
    AdrienL Dataiker, Alpha Tester Posts: 196 Dataiker


    There was a bug around the Pivot processor, which was fixed in DSS 4.0.4.

    As for the "sorted" dataset:

    The Pivot processor indeed requires the input to be naturally ordered (the index column must have identical values on adjacent rows), which make it incompatible/non-deterministic with parallel or undefined-sorting data sources.

    A local dataset with several files (which is the case of managed filesystem datasets) for instance will not work properly with this processor, because each file is processed in parallel. We will add clearer warnings on this processor in a future update.

    Also, we are working on a system that would force ordered, single-threaded processing of parallel/unordered data sources so that they can still work with this kind of processors. This feature should be available in DSS 4.1, scheduled for this summer.

Setup Info
      Help me…