Want to Stop Rebuilding "Expensive" Parts of your Flow? Explicit Builds are the Answer!READ MORE

Not able to install "snowflake-snowpark-python" package in python environment

Solved!
snowflakeuser
Level 2
Not able to install "snowflake-snowpark-python" package in python environment

Operating system used: windows

0 Kudos
1 Solution
AlexT
Dataiker
Dataiker

Hi @snowflakeuser ,

Please note if you are using Dataiku Online, you can select Python3.8 to create the code env which is required for the package, please refer to the below screenshots:

Screenshot 2022-08-08 at 18.47.44.pngScreenshot 2022-08-08 at 18.48.03.png

 

Let us know if you face any further issues , you can also contact us directly for Dataiku Online specific issues  : https://knowledge.dataiku.com/latest/kb/dku-online/obtaining-support.html 

View solution in original post

0 Kudos
7 Replies
sergeyd
Dataiker
Dataiker
0 Kudos
AlexT
Dataiker
Dataiker

Hi @snowflakeuser ,

Please note if you are using Dataiku Online, you can select Python3.8 to create the code env which is required for the package, please refer to the below screenshots:

Screenshot 2022-08-08 at 18.47.44.pngScreenshot 2022-08-08 at 18.48.03.png

 

Let us know if you face any further issues , you can also contact us directly for Dataiku Online specific issues  : https://knowledge.dataiku.com/latest/kb/dku-online/obtaining-support.html 

0 Kudos
snowflakeuser
Level 2
Author

Hi @AlexT 
I created an environment with python 3.8 and successfully installed snowpark but I am getting problem with pandas==1.3.5  preinstalled version. Is there a way to downgrade the pandas version(pandas==1.0.5), I am trying to uninstall but it is not allowing me to do.

0 Kudos
AlexT
Dataiker
Dataiker

Hi,

There is no way for you to downgrade from the launchpad. You can open a support chat we can help with that once you enable remote support:

https://knowledge.dataiku.com/latest/kb/dku-online/obtaining-support.html

 

0 Kudos
snowflakeuser
Level 2
Author

Hi @AlexT 

I enabled remote support but live chat with Dataiku link is not working.

0 Kudos
AlexT
Dataiker
Dataiker

Hi,

The chat must be blocked by your Browser plugins, for example. 

 I will need the instance name and instance URL. You can message them directly or send an email to 

support-online  [at]  dataiku [dot] com ( replace accordingly( 

0 Kudos
snowflakeuser
Level 2
Author

Hi @AlexT@sergeyd 
thanks for your help, problem solved

0 Kudos