Join us on July 16th as we explore real-world Reinforcement Learning Learn more

"Filter" does not work for long int-string?

Level 2
"Filter" does not work for long int-string?

Hi,



I have a column specified as "Text", containing some ID in integer form with 14 digits, (e.g. 12345678912340).



For those keys I have 622 distinct values for which I now want to filter-in one of those.



When I click on the column and select "Filter" in "Explore" view and tick the corresponding value, nothing happens. To cross check, I selected another column with a similar structure ("Text" consisting of integer values), but with only 3 digits (e.g. 123). There, filtering works as expected. Is this a technical issue or am I missing something here?



Edit: Here are Screenshots of both cases:



Non-Working (nothing happens on ticking 3007207....; notice "All" at the filter above the selection):



Counter-Example for working filter (after ticking "281", the table gets refreshed, column header turns blue + filter symbol appears and only rows with the value matching the filtering condition are shown):





Thanks in advance!

0 Kudos
3 Replies
Dataiker
Dataiker

Hi,



The list view of the filter on the Explore screen of a Dataset contains a sample of the distinct values. Since you have many distinct values, the one you are looking for may not appear.



In order to filter for one specific value, I advise to use the "text" view of the filter, as shown below:





Hope it helps,



Alex

0 Kudos
Level 2
Author
Hi,
thanks four your reply. Filtering the text manually worked for me.
However, I configured my sample to incorporate the whole data set, and again ticking the value does not trigger the filter. Shouldn't it work like that in that case?
0 Kudos
Dataiker
Dataiker
Hi,
If you really want to have all values selected by the filter from the full dataset, I advise using the filter option directly in the Configure Sample left panel. This will be faster and less risky for your browser to crash if you have many rows.
Regarding the other issue you mention, have you tried resetting the filter?
Cheers,
Alex
0 Kudos
Labels (2)