New to Dataiku DSS? Try out our NEW Quick Start Programs today and get onboarded on the product in just one hour! Let's go

not able to create python code env, getting SSL EOF error

Go14
Level 1
not able to create python code env, getting SSL EOF error

Hi 

I was able to create and update the python code env till yesterday. suddenly I am not able to create new python code env or update the existing python code env. 

whereas i am not facing any issue with custom R code env. I am getting the below error while create new python code env or update or install any new python package in existing code env. 

ERROR: Could not find a version that satisfies the requirement pandas==0.23.4ERROR: No matching distribution found for pandas==0.23.4Could not fetch URL https://pypi.org/simple/pandas/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pandas/ (Caused by SSLError(SSLEOFError(8, 'EOF occurred in violation of protocol (_ssl.c:877)'),)) - skipping

 

I am facing this issue only in Dataiku Web interface. If I activate the same code env in CLI console, I am able to install the python package without any issue. 

I am using Dataiku v7.0.2 version in both Dev and preprod env. But I am facing this issue only in Dev not in Preprod(able to create new python code env).

Could you please share me your suggestions to resolve this issue. 

Note:
I have verified the code env and basic python installation supports TLS1.2. I am running python version 3.6.8 in both env with Pip version 9.0.3.

 

 

 

0 Kudos
0 Replies
Labels (3)
A banner prompting to get Dataiku DSS