Do you know the History of Data Science? READ MORE

Public webapp with Dash

Solved!
clemEs
Level 2
Public webapp with Dash

Hi,

I used to develop webapp with the standard webapp and I moved to Dash webapp since DSS 9.

Normally I publish them with the public webapp system.

I tried to do the same with the Dash application but it doesn't seem to be working as it still ask me to authenticate to DSS.

 

HTTP error 401 (Not authenticated). The webapp backend mandates that the current browsser has been logged in into DSS.

 

My setup in the webapp backend doesn't ask for logging.

 

Is it normal as it should public ?

 

Cheers 🙂

0 Kudos
1 Solution
adamnieto
Neuron
Neuron

Hi @clemEs ,

It should be the same for Dash web apps I believe. I think there should be 2 ways to resolve this :

1. Check your settings for the web application by going to the settings tab. Make sure the "Require authentication" checkbox is not checked. 

auth.PNG

 

2. Sometimes DSS admins have a setting where it says all web apps require authentication. So check with a DSS admin that this is not the case. They should see it under the WebApps section in "/admin/general/security/". 

Important note:  Make sure to stop your web app from the web apps tab in your DSS project you should see a "Stop backend" red button. Try pressing it and restarting again. Sometimes this helps restart and reset the web app so that it realizes it is public. 

Hope this helps!

Adam

View solution in original post

2 Replies
adamnieto
Neuron
Neuron

Hi @clemEs ,

It should be the same for Dash web apps I believe. I think there should be 2 ways to resolve this :

1. Check your settings for the web application by going to the settings tab. Make sure the "Require authentication" checkbox is not checked. 

auth.PNG

 

2. Sometimes DSS admins have a setting where it says all web apps require authentication. So check with a DSS admin that this is not the case. They should see it under the WebApps section in "/admin/general/security/". 

Important note:  Make sure to stop your web app from the web apps tab in your DSS project you should see a "Stop backend" red button. Try pressing it and restarting again. Sometimes this helps restart and reset the web app so that it realizes it is public. 

Hope this helps!

Adam

View solution in original post

clemEs
Level 2
Author

Yes it did work, thank you. I guess the check, uncheck did the job 🙂

Cheers

A banner prompting to get Dataiku DSS