pdarima can't be installed

Solved!
mahmoud_shihab
Level 3
pdarima can't be installed

I'm currently trying to install the recommended timeseries machine learning packages within dataiku (please see attachement).

When I do, I get the following error:

 

                               ^
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:580:45: note: declared here
       Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
                                                   ^~~~~~~~~~~~~~~~~~~
      pmdarima/arima/_arima.c:27634:25: warning: ‘_PyUnicode_get_wstr_length’ is deprecated [-Wdeprecated-declarations]
                               (PyUnicode_GET_SIZE(**argname) != PyUnicode_GET_SIZE(key)) ? 1 :
                               ^
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:446:26: note: declared here
       static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
                                ^~~~~~~~~~~~~~~~~~~~~~~~~~
      pmdarima/arima/_arima.c:27634:25: warning: ‘_PyUnicode_get_wstr_length’ is deprecated [-Wdeprecated-declarations]
                               (PyUnicode_GET_SIZE(**argname) != PyUnicode_GET_SIZE(key)) ? 1 :
                               ^
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:446:26: note: declared here
       static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
                                ^~~~~~~~~~~~~~~~~~~~~~~~~~
      pmdarima/arima/_arima.c:27634:25: warning: ‘PyUnicode_AsUnicode’ is deprecated [-Wdeprecated-declarations]
                               (PyUnicode_GET_SIZE(**argname) != PyUnicode_GET_SIZE(key)) ? 1 :
                               ^
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:580:45: note: declared here
       Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
                                                   ^~~~~~~~~~~~~~~~~~~
      pmdarima/arima/_arima.c:27634:25: warning: ‘_PyUnicode_get_wstr_length’ is deprecated [-Wdeprecated-declarations]
                               (PyUnicode_GET_SIZE(**argname) != PyUnicode_GET_SIZE(key)) ? 1 :
                               ^
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:446:26: note: declared here
       static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
                                ^~~~~~~~~~~~~~~~~~~~~~~~~~
      pmdarima/arima/_arima.c: In function ‘__Pyx_decode_c_string’:
      pmdarima/arima/_arima.c:29855:9: warning: ‘PyUnicode_FromUnicode’ is deprecated [-Wdeprecated-declarations]
               return PyUnicode_FromUnicode(NULL, 0);
               ^~~~~~
      In file included from /usr/local/include/python3.9/unicodeobject.h:1026,
                       from /usr/local/include/python3.9/Python.h:93,
                       from pmdarima/arima/_arima.c:39:
      /usr/local/include/python3.9/cpython/unicodeobject.h:551:42: note: declared here
       Py_DEPRECATED(3.3) PyAPI_FUNC(PyObject*) PyUnicode_FromUnicode(
                                                ^~~~~~~~~~~~~~~~~~~~~
      error: Command "gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -DHAVE_CBLAS -I/home/dss/dataiku/data/code-envs/python/EGAS_Timeseries/lib/python3.9/site-packages/numpy/core/include -Ipmdarima/arima/_arima_fast_helpers.h -I/home/dss/dataiku/data/code-envs/python/EGAS_Timeseries/lib/python3.9/site-packages/numpy/core/include -Ibuild/src.linux-x86_64-3.9/numpy/distutils/include -I/home/dss/dataiku/data/code-envs/python/EGAS_Timeseries/include -I/usr/local/include/python3.9 -c pmdarima/arima/_arima.c -o build/temp.linux-x86_64-3.9/pmdarima/arima/_arima.o -MMD -MF build/temp.linux-x86_64-3.9/pmdarima/arima/_arima.o.d -msse -msse2 -msse3" failed with exit status 1
      INFO:
      ########### EXT COMPILER OPTIMIZATION ###########
      INFO: Platform      :
        Architecture: x64
        Compiler    : gcc
      
      CPU baseline  :
        Requested   : 'min'
        Enabled     : SSE SSE2 SSE3
        Flags       : -msse -msse2 -msse3
        Extra checks: none
      
      CPU dispatch  :
        Requested   : 'max -xop -fma4'
        Enabled     : SSSE3 SSE41 POPCNT SSE42 AVX F16C FMA3 AVX2 AVX512F AVX512CD AVX512_KNL AVX512_KNM AVX512_SKX AVX512_CLX AVX512_CNL AVX512_ICL
        Generated   : none
      INFO: CCompilerOpt.cache_flush[857] : write cache to path -> /tmp/pip-install-0aio0cc8/pmdarima_efe601bcd4004abfbac3fd1bfd109d9d/build/temp.linux-x86_64-3.9/ccompiler_opt_cache_ext.py
      [end of output]
  
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure
  Running setup.py install for pmdarima: finished with status 'error'
× Encountered error while trying to install package.
╰─> pmdarima
note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure.

 

Can someone help?

Operating system used: Red Hat 8 VM
Dataiku version: Dataiku 11 Enterprise
Browser used: Chrome

0 Kudos
1 Solution
AlexT
Dataiker

Hi @mahmoud_shihab ,
Could please try to use Python 3.6 or 3.7 code env instead of 3.9? I was able to reproduce the issue on Python 3.9, time series and Visual ML code may not yet be compatible with Python3.9 code envs. 

I successfully built Python 3.6 and 3.7 with the following requirements:


statsmodels==0.12.2
gluonts==0.8.1
pmdarima==1.2.1
mxnet==1.7.0.post2
scikit-learn>=0.20,<0.21
scipy>=1.2,<1.3
xgboost==0.82
lightgbm>=3.2,<3.3
jinja2>=2.10,<2.11
MarkupSafe<2.1.0
flask>=1.0,<1.1
cloudpickle>=1.3,<1.6

Thanks,

 

View solution in original post

0 Kudos
1 Reply
AlexT
Dataiker

Hi @mahmoud_shihab ,
Could please try to use Python 3.6 or 3.7 code env instead of 3.9? I was able to reproduce the issue on Python 3.9, time series and Visual ML code may not yet be compatible with Python3.9 code envs. 

I successfully built Python 3.6 and 3.7 with the following requirements:


statsmodels==0.12.2
gluonts==0.8.1
pmdarima==1.2.1
mxnet==1.7.0.post2
scikit-learn>=0.20,<0.21
scipy>=1.2,<1.3
xgboost==0.82
lightgbm>=3.2,<3.3
jinja2>=2.10,<2.11
MarkupSafe<2.1.0
flask>=1.0,<1.1
cloudpickle>=1.3,<1.6

Thanks,

 

0 Kudos

Labels

?
Labels (3)
A banner prompting to get Dataiku