dku-apideployer-apinode-base, repository does not exist or may require 'docker login'

RSalerno
Level 1
Level 1
dku-apideployer-apinode-base, repository does not exist or may require 'docker login'

Hello, 

when i try to update API in API deployer it gives me this error after clean image docker with this command

"docker system prune -a -f"

the error is showed in attached picture

can someone help me? 

thanks

0 Kudos
1 Reply
sergeyd
Dataiker
Dataiker

Hi @RSalerno 

As this has been reported also in a support ticket, I will just copy the possible solution here:

This error indicates that you might no longer have the base image (hence the fact that docker can't find it, and defaults to trying to pull it from the Hub).
Please note that the base image must be built at each DSS upgrade. 
Check if you have base image actually present:
docker image ls
 
Then please make sure you can authenticate with your docker registry:
docker login <registry public hostname>
 
If you have a base image present and can authenticate successfully, try rebuilding image and push it to docker registry:
./bin/dssadmin build-base-image --type api-deployer

 

0 Kudos
A banner prompting to get Dataiku DSS
Public