code environments mac

Highlighted
larispardo
Level 3
code environments mac

Hello, I have been trying to install the code environments on my mac and I can only create the python2.7 environment, when I tell DSS to use the managed python3.6 says it is not in path. when I tell it to use conda says "conda" no such file or directory, and when I give it custom I give my anaconda directory where my python 3 is, but it gets the error "pip._vendor.requests.packages.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out.".



Any help will be greatly appreciated



Another problem I have gotten since this was posted, I tried to use R that I integrated using the command "install-R-integration" but I get that the package Dataiku does not exist:





P.S. image answer from comment:





---- comment ----





(image 1)





(image 2)





(image 3)





(image 4)





(image 5)





(image 6)

0 Kudos
3 Replies
Alex_Combessie Dataiker
Dataiker
Re: code environments mac
Hello,

I confirm that it works on my mac (High Sierra 10.13.3) as an external conda environment created through Anaconda Navigator 1.7 and Anaconda3 4.4.4. I tested it on DSS 4.1.5. It also works as a managed conda environment, which is the recommended way to work with conda in DSS, provided you have unrestricted Internet access.

Could you try and match the versions listed above and see if it works? Let us know if you find the root cause of the issue by posting any additional error messages and commands.

Cheers,

Alexandre
0 Kudos
larispardo
Level 3
Re: code environments mac
Okey, I had an finding while working with this issue today. I notices I had DSS 4.1.3 and upgrade it. When I entered I had the same issue I had when I first posted this question, so I quit and opened it again and the same thing "cannot run "conda"" (more info in the link with the images) so I stopped DSS from the terminal and started again, and only then I was able to create the environment using conda. I am not sure why this happened, but I really appreciate your help.
https://imgur.com/a/OXInE
0 Kudos
Alex_Combessie Dataiker
Dataiker
Re: code environments mac
Indeed, we added support for conda 4.4 in the version 4.1.4 of DSS. See our official release notes: https://doc.dataiku.com/dss/latest/release_notes/4.1.html#id2. Hence upgrading DSS to the latest version is the solution.
0 Kudos
Labels (1)