Submit your inspiring success story or innovative use case to the 2022 Dataiku Frontrunner Awards! ENTER YOUR SUBMISSION

UnicodeEncodeError: 'ascii' codec can't encode character u'\u2018' in position 923

brndnmnn
Level 1
UnicodeEncodeError: 'ascii' codec can't encode character u'\u2018' in position 923

Hello,

I'm a consultant attempting to configure Dataiku for a client - I've simply followed the documentation available for the most part and ran into issues that I've mostly been able to solve either with this forum or StackOverflow.  I'm attempting to start a cluster per the documentation @ Guided setup 1: Deploy in a new VNet with Elastic Compute — Dataiku DSS 10.0 documentation but running into the following error:

  File "/data/dataiku/dss_data/plugins/installed/aks-clusters/python-lib/dku_azure/utils.py", line 18, in run_and_process_cloud_error    raise eUnicodeEncodeError: 'ascii' codec can't encode character u'\u2018' in position 923: ordinal not in range(128)[2022-05-24 15:13:08,830] [15950/MainThread] [INFO] [dataiku.base.socket_block_link] Client closed

 I'm at a bit of a loss here as to what would be causing the encode error as it seems to be within an internal python script.  Apologies as I'm more of a back-end guy and not a developer so any help ascertaining the issue here would be appreciated.

Thanks!

0 Kudos
2 Replies
AlexT
Dataiker
Dataiker

Hi,

The error 'ascii' codec can't encode character u'\u2018' suggests a python 2 vs 3 code mismatch. 

Can you please confirm

1) the code env version for the AKS plugin?

2) Version of the AKS plugin(latest would be 2.0.2. )  and DSS version you have installed.  

1. Make sure you select python3.6 or when creating the code env , if one is already created you can try to create a new once you upgrade the plugin to a version to a version that supports Python3.

Screenshot 2022-05-24 at 21.50.38.pngScreenshot 2022-05-24 at 21.52.25.png

 

0 Kudos
brndnmnn
Level 1
Author

Hello,

Thank you for the response!  That was indeed all I needed to do, change the code env - working fine now.