Check out the first Dataiku 8 Deep Dive focusing on Productivity on October 29th Read More

Suitable Kubernetes Cluster for dataiku 7.03

Level 1
Suitable Kubernetes Cluster for dataiku 7.03

Hi can anybody suggest which Kubernetes version is supported for Dataiku 7.03

We are trying to deploy model into Kubernetes Cluster, but version is not supporting. 

0 Kudos
1 Reply
Dataiker
Dataiker

Hi,

Your Kubernetes is too recent, as support for "apps/v1beta2" was removed in Kubernetes 1.16.

You can do either of the following:

  • Upgrade to DSS 8.0.1 which adds support for more recent Kubernetes
  • Downgrade to Kubernetes 1.15
  • Go to the DSS installation directory and edit the resources/api-deployer/kubernetes/deployment.yaml.template file. In the first line, replace apps/v1beta2 by apps/v1