The Dataiku Frontrunner Awards have just launched to recognize your achievements! Submit Your Entry

R Integration Fail (Ubuntu 16.04) IRkernel non-zero exit status

Solved!
SallmanGhanem
Level 2
R Integration Fail (Ubuntu 16.04) IRkernel non-zero exit status

Error Log:

 

***************************************************************

/home/dataiku/dataiku-dss-8.0.2/scripts/_startup.inc.sh: line 190: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory

[+] Saving installation log to /home/dataiku/dss/run/install.log

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

[+] Checking dependencies

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

+ Detected OS distribution : ubuntu 16.04

+ Checking required packages...

[+] Installing required R packages into /home/dataiku/dss/R.lib

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

During startup - Warning messages:

1: Setting LC_CTYPE failed, using "C"

2: Setting LC_COLLATE failed, using "C"

3: Setting LC_TIME failed, using "C"

4: Setting LC_MESSAGES failed, using "C"

5: Setting LC_MONETARY failed, using "C"

6: Setting LC_PAPER failed, using "C"

7: Setting LC_MEASUREMENT failed, using "C"

Checking installed packages ...

Package not installed: IRkernel

Installing packages: IRkernel

Warning: dependency 'pbdZMQ' is not available

trying URL 'https://cloud.r-project.org/src/contrib/IRkernel_1.1.1.tar.gz'

Content type 'application/x-gzip' length 57656 bytes (56 KB)

==================================================

downloaded 56 KB


/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

During startup - Warning messages:

1: Setting LC_CTYPE failed, using "C"

2: Setting LC_COLLATE failed, using "C"

3: Setting LC_TIME failed, using "C"

4: Setting LC_MESSAGES failed, using "C"

5: Setting LC_MONETARY failed, using "C"

6: Setting LC_PAPER failed, using "C"

7: Setting LC_MEASUREMENT failed, using "C"

ERROR: dependency 'pbdZMQ' is not available for package 'IRkernel'

* removing '/home/dataiku/dss/R.lib/IRkernel'


The downloaded source packages are in

'/tmp/Rtmp0dj0yn/downloaded_packages'

Checking installed packages ...

Package not installed: IRkernel

Error: at least one package failed to install required version

In addition: Warning message:

In install.packages(toInstall, "/home/dataiku/dss/R.lib", repos = "https://cloud.r-project.org") :

installation of package 'IRkernel' had non-zero exit status

Execution halted

 

 

 

 

Also I have installed the following packages on the OS system:

 

 

 

RUN echo "deb http://cran.rstudio.com/bin/linux/ubuntu xenial/" | tee -a /etc/apt/sources.list \
   &&  gpg --keyserver keyserver.ubuntu.com --recv-key E298A3A825C0D65DFD57CBB651716619E084DAB9 \
   &&  gpg -a --export E298A3A825C0D65DFD57CBB651716619E084DAB9 | apt-key add - \
   &&  apt-get update \
   &&  apt-get install -y r-base r-base-dev

# Needed packages
RUN apt-get install -y \
  yum \
  file \
  acl \
  libexpat1 \
  git \
  nginx \
  unzip \
  zip \
  default-jre-headless \
  python3 \
  libfreetype6 \
  libgfortran3 \
  libgomp1 \
  libicu-dev \
  curl \
  openssl \
  libxml2-dev \
  python-dev \
  python3-dev \
  dos2unix \
  libcurl4-openssl-dev \
  libssl-dev \
  && apt-get clean all

 

 

 

  

I hope someone can help out with this IRkernel I am thinking maybe the problem is with the packages on the Ubuntu... but I have no clue.

 

Edit 1: So looking at the documentation it seems dataiku supports R 3.4 to 3.6 I changed the source from

 

"deb http://cran.rstudio.com/bin/linux/ubuntu xenial/"

 

to

 

"deb http://cloud.r-project.org/bin/linux/ubuntu xenial-cran35/"

 

checking to see if that works.

0 Kudos
1 Solution
SallmanGhanem
Level 2
Author

Changing to R 3.6 from R 4 worked it is running now! (See Edit 1)

View solution in original post

10 Replies
SallmanGhanem
Level 2
Author

Changing to R 3.6 from R 4 worked it is running now! (See Edit 1)

View solution in original post

sergeyd
Dataiker
Dataiker

Hi @SallmanGhanem 

That's not about DSS. Latest pbdZMQ version is just not available for R3.4. You will need to have R3.5 or even better R3.6 installed to get access to all recent R packages. 

Alternatively, you can use this command which will install R packages available for that timestamp:

./bin/dssadmin install-R-integration -repo https://cran.microsoft.com/snapshot/2020-12-12/

Basically, this will allow installing the version of pbdZMQ that was available for R.3.4. 

TheophileT
Dataiker
Dataiker

Hi,

It looks like pbdZMQ is missing. How are you doing your R integration?

Can you check if pdbZMQ is installed in R. You can use

 

R -e "installed.packages()" | grep pbdZMQ

 

What happens if you install it manually. You can do that with (you may need to run that with sudo)

 

R -e "install.packages(c('pbdZMQ'), repos='https://cran.rstudio.com')"

 

 

0 Kudos
Marek
Level 2

After a recent DSS upgrade have faced the same issue with R integration, i.e. was unable to rebuild the R 3.4.3 environments due to unavailable pbdZMQ package.

Manual package installation from https://cran.rstudio.com did not help, however worked from https://cran.microsoft.com/snapshot/2020-12-12/.

sergeyd
Dataiker
Dataiker

Hi @Marek 

That's strange to hear as 2020-12-12 is the exact date before the version of pbdZMQ non-compatible with R.3.4 has been released (2020-12-13): https://cran.r-project.org/web/packages/pbdZMQ/index.html

I don't know. Try older snapshot: https://cran.microsoft.com/snapshot/2020-06-30/

What error did you get? Can you post the log snippet? 

UPD: Sorry, mistakenly read that using 2020-12-12 is not working as well. 

0 Kudos
Marek
Level 2

pbdZMQ installation worked with repos="https://cran.microsoft.com/snapshot/2020-12-12/".

However I am still unable to update the R environment because of the IRkernel installation error, despite this package seems to be installed.

Package not installed: IRkernel
Error: at least one package failed to install required version
In addition: Warning message:
In install.packages(toInstall, "/home/dataiku/dss_data/code-envs/R/R/R.lib", :
installation of package ‘IRkernel’ had non-zero exit status
> "IRkernel" %in% installed.packages()
[1] TRUE

 Any ideas how to solve that?

0 Kudos
sergeyd
Dataiker
Dataiker

Please post complete update.log

0 Kudos
Marek
Level 2

Issue solved, by manually installing pbdZMQ package in terminal session into the relevant environment i.e.

> cd /home/dataiku/dss_data/code-envs/R/R/bin
> R -e "install.packages('pbdZMQ', repos='https://cran.microsoft.com/snapshot/2020-12-12/')"
sergeyd
Dataiker
Dataiker

Ah, I see. Basically, you just needed to put this snapshot URL either into global settings on Administration->Settings->Misc->Code envs or within code-env itself via unchecking "Inherit global settings" on General tab. 

Anyway, glad this is resolved now. 

 

0 Kudos
Pavan
Level 2

Thank you very much. Had the exact same issue. Was able to resolve with your inputs.

0 Kudos
A banner prompting to get Dataiku DSS