Check out the first Dataiku 8 Deep Dive focusing on Productivity on October 29th Read More

Limitations on packages versions

Level 3
Level 3
Limitations on packages versions

Hi,

where can I find the list of packages versions limitations in DSS?


P.S: As an example I had trouble running my code with scikit-learn 0.23.2 and I solved my issue using scikit-learn 0.22 instead.

0 Kudos
2 Replies
Dataiker
Dataiker

Hi, 

DSS has a built-in Python code environment and a possibility to create custom environments. We recommend using custom ones if you want to install new packages or change the version of the existing ones.

You may find more information about environments here:

https://doc.dataiku.com/dss/latest/python/packages.html

 

Once a new code environment is created you can find a list of packages and install new ones on it's dedicated page (Administration -> Code Envs -> Your environment)

 

Screenshot 2020-10-05 at 17.56.18.png

Andrey Avtomonov
R&D Engineer @ Dataiku
0 Kudos
Level 3
Level 3
Author

Thank you for the reply!
I'm aware that I can create my python env and install my packages. What I meant is that testing my service it gave me an error about not finding sklearn, because in one of the dataiku python scripts (not the ones written by me) it was trying to import sklearn.ensemble.partial_dependence (if I remember well), which in sklearn 0.23 is not available anymore at the same place. It was not a problem, because as you said, I installed sklearn 0.22 on my environment and everything worked fine.
What I was wondering is if there is a list of the compatible packages versions, so that if I create a project I already know which versions to install in my env.

Regards

0 Kudos