Get to know ben_p with this User Highlight Learn More

Issue building base image for dockerized execution

Level 3
Issue building base image for dockerized execution

I'm currently building a base image for the EKS/Athena/Glue setup (basically checking a list here) but I can't build the base-exec image. After running ./bin/dssadmin build-container-exec-base-image, I get :

(...)
Collecting more-itertools (from zipp>=0.5->importlib-metadata; python_version < "3.8"->jsonschema!=2.5.0,>=2.4->nbformat<4.5,>=4.4)
Downloading https://files.pythonhosted.org/packages/df/8c/c278395367a46c00d28036143fdc6583db8f98622b83875403f16473509b/more-itertools-8.1.0.tar.gz (78kB)
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-build-_CAF7v/more-itertools/setup.py", line 5, in <module>
from more_itertools import __version__
File "more_itertools/__init__.py", line 1, in <module>
from .more import * # noqa
File "more_itertools/more.py", line 480
yield from iterable
^
SyntaxError: invalid syntax

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-_CAF7v/more-itertools/
You are using pip version 8.1.2, however version 19.3.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
The command '/bin/sh -c build/install-python-packages.sh pip' returned a non-zero code: 1


Is is possible to tweak this?

Best,

Romain

0 Kudos
2 Replies
Dataiker
Dataiker

Hi Romain,

EDIT: My answer is probably not valid. Please get in touch with our support team.

I'm not an expert on the topic. For me, it seems related to the Python version (more-itertools no longer supports Python 2) and Python environement for DSS.

If that does not help, I can ping someone from our architect team.

Cheers,
Jeremy

Jeremy, Product Manager at Dataiku
0 Kudos
Level 3
Author

Will do, thanks Jeremy!

0 Kudos