Submit your inspiring success story or innovative use case to the 2022 Dataiku Frontrunner Awards! ENTER YOUR SUBMISSION

Installing R-Integration onto DSS

aidan-shumaker
Level 1
Installing R-Integration onto DSS

Hello! We have been trying to install r-integration and are running into issues. Attached are the logs of the times we have tried and the issue that we are seeing. Documentation that we are following: https://doc.dataiku.com/dss/latest/installation/custom/r.html

 

Logs: 

[root@slddgnd001:/opt]
# sudo -i "/opt/dataiku/dataiku-dss-9.0.4/scripts/install/install-deps.sh" -without-java -without-python -with-r
+ Detected OS distribution : redhat 7.9
+ Checking required repositories...
/usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:22: UserWarning: Setuptools will stop working on Python 2
************************************************************
You are running Setuptools on Python 2, which is no longer
supported and
>>> SETUPTOOLS WILL STOP WORKING <<<
in a subsequent release (no sooner than 2020-04-20).
Please ensure you are installing
Setuptools using pip 9.x or later or pin to `setuptools<45`
in your environment.
If you have done those things and are still encountering
this message, please comment in
https://github.com/pypa/setuptools/issues/1458
about the steps that led to this unsupported combination.
************************************************************
sys.version_info < (3,) and warnings.warn(pre + "*" * 60 + msg + "*" * 60)
+ Adding EPEL repository ...
* Warning: you may need to enable the RedHat 'optional' repository in case of missing dependencies
* See https://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F
/usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:22: UserWarning: Setuptools will stop working on Python 2
************************************************************
You are running Setuptools on Python 2, which is no longer
supported and
>>> SETUPTOOLS WILL STOP WORKING <<<
in a subsequent release (no sooner than 2020-04-20).
Please ensure you are installing
Setuptools using pip 9.x or later or pin to `setuptools<45`
in your environment.
If you have done those things and are still encountering
this message, please comment in
https://github.com/pypa/setuptools/issues/1458
about the steps that led to this unsupported combination.
************************************************************
sys.version_info < (3,) and warnings.warn(pre + "*" * 60 + msg + "*" * 60)
Cannot open: http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm. Skipping.
Error: Nothing to do
Loaded plugins: langpacks, product-id, subscription-manager

[root@slddgnd001:/opt]
# su dataiku

[dataiku@slddgnd001:/opt]
$ cd dataiku/dss_data/

[dataiku@slddgnd001:/opt/dataiku/dss_data]
$ ./bin/dssadmin install-R-integration
[+] Saving installation log to /opt/dataiku/dss_data/run/install.log
[+] Checking dependencies
+ Detected OS distribution : redhat 7.9
+ Checking required packages...
*** Error: package nginx not found
*** Error: package R-core-devel not found
*** Error: package libicu-devel not found
*** Error: package libcurl-devel not found
*** Error: package openssl-devel not found
*** Error: package libxml2-devel not found

[-] Dependency check failed
[-] You can install required dependencies with:
[-] sudo -i "/opt/dataiku/dataiku-dss-9.0.4/scripts/install/install-deps.sh" -without-java -without-python -with-r
[-] You can also disable this check with the -noDeps option


[dataiku@slddgnd001:/opt/dataiku/dss_data]
$ ./bin/dssadmin install-R-integration -repo https://jfrog.info53.com/artifactory
[+] Saving installation log to /opt/dataiku/dss_data/run/install.log
[+] Checking dependencies
+ Detected OS distribution : redhat 7.9
+ Checking required packages...
*** Error: package nginx not found
*** Error: package R-core-devel not found
*** Error: package libicu-devel not found
*** Error: package libcurl-devel not found
*** Error: package openssl-devel not found
*** Error: package libxml2-devel not found

[-] Dependency check failed
[-] You can install required dependencies with:
[-] sudo -i "/opt/dataiku/dataiku-dss-9.0.4/scripts/install/install-deps.sh" -without-java -without-python -with-r
[-] You can also disable this check with the -noDeps option


Operating system used: Linux

0 Kudos
1 Reply
sergeyd
Dataiker
Dataiker

Hi @aidan-shumaker 

This looks that the system (not DSS) Python 2.7 does not work anymore, and maybe even that yum does not work anymore and cannot install internet-based files.

Fixing this will probably require sysadmin intervention/expertise with potentially (?) upgrading the underlying OS?

Can you please check that you can run yum install and install the required packages manually: 

sudo yum install http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
sudo yum install nginx R-core-devel libicu-devel libcurl-devel openssl-devel libxml2-devel

?

0 Kudos