The Dataiku Frontrunner Awards are now accepting submissions until July 15 to recognize your achievements! ENTER YOUR SUBMISSION

How to allocate more memory to DSS on local machine ? (MacOS)

UserBird
Dataiker
Dataiker
How to allocate more memory to DSS on local machine ? (MacOS)

When starting DSS in the terminal, I get the following warning : 



*** WARNING: maximum number of open files (ulimit -n) is 1024, lower than recommended minimum 4096



*** WARNING: maximum number of user processes (ulimit -u) is 709, lower than recommended minimum 4096



How can I remove those limits and will that improve DSS performance ?



Thanks    

0 Kudos
1 Reply
Clément_Stenac
Dataiker
Dataiker
Hi,

These settings are related to "ulimits" on OS X. They are safety limits imposed by the OS. These settings won't have any impact on DSS performance. You'll actually need to increase them only if you get errors like "too many open files" or "insufficient system resources".

The settings can be changed temporarily by entering these commands before running DSS:

ulimit -n 4096
ulimit -u 4096

To change them in a persistent way, see: http://unix.stackexchange.com/questions/108174/how-to-persist-ulimit-settings-in-osx-mavericks
0 Kudos
Labels (1)
A banner prompting to get Dataiku DSS
Public