Discover this year's submissions to the Dataiku Frontrunner Awards and give kudos to your favorite use cases and success stories!READ MORE

Error when installing Dataiku for ubuntu 21.04 (OS not supported)

Solved!
axel_alvarez
Level 1
Error when installing Dataiku for ubuntu 21.04 (OS not supported)

Hey, I'm having problems installing Dataiku 9 (https://www.dataiku.com/product/get-started/linux/) for Ubuntu 21.04. I haven't been able to fix it. 

This is the error at the moment of launching the installation script.

[!] DATA_DIR contains a previously failed install of DSS
[!] Moving it out of the way and proceeding
[!] *****************************************************
[+] Creating data directory: DATA_DIR
[+] Saving installation log to /home/axel/DataIKU/DATA_DIR/run/install.log
[*] Could not find suitable version of Java
[+] Checking required dependencies
+ Detected OS distribution : ubuntu 21.04
*** OS distribution not supported *** ubuntu 21.04

[-] Dependency check failed
[-] You can install required dependencies with:
[-] sudo -i "/home/axel/DataIKU/dataiku-dss-9.0.1/scripts/install/install-deps.sh"
[-] You can also disable this check with the -n installer flag

 

I've tried with the sudo -i command but it say that OS distribution is not supported

0 Kudos
1 Solution
sergeyd
Dataiker
Dataiker

Hi @axel_alvarez,

You are running Ubuntu 21.04 and this OS is not in the supported list: 

https://doc.dataiku.com/dss/latest/installation/custom/requirements.html#linux

so this is expected to have that failure message.

You can try modifying the install-deps.sh script to bypass this check but the recommended way will be to use Ubuntu 20.04 or any other supported OS from the list I shared above. 

Thanks. 

View solution in original post

1 Reply
sergeyd
Dataiker
Dataiker

Hi @axel_alvarez,

You are running Ubuntu 21.04 and this OS is not in the supported list: 

https://doc.dataiku.com/dss/latest/installation/custom/requirements.html#linux

so this is expected to have that failure message.

You can try modifying the install-deps.sh script to bypass this check but the recommended way will be to use Ubuntu 20.04 or any other supported OS from the list I shared above. 

Thanks. 

Labels

?
Labels (1)
A banner prompting to get Dataiku