Survey banner
The Dataiku Community is moving to a new home! Some short term disruption starting next week: LEARN MORE

Dataiku not starting due to issue with nginx

Solved!
Schiggy
Level 2
Dataiku not starting due to issue with nginx

Hi everyone

When I try to start dss, I get an error associated with nginx. See the following two commands.

$ /home/.../dataiku/dss_data/bin/dss start

Waiting for DSS supervisor to start ...
backend                          STARTING
ipython                          STARTING
nginx                            BACKOFF   Exited too quickly (process log may have details)
DSS started, pid=6238
Waiting for DSS backend to start ....

 

$ /home/.../dataiku/dss_data/bin/dss status

backend                          RUNNING   pid 6250, uptime 0:00:20
ipython                          RUNNING   pid 6251, uptime 0:00:20
nginx                            FATAL     Exited too quickly (process log may have details)

 

When I check the logs, I see the following.

$ sudo nano home/.../dataiku/dss_data/run/nginx.log

nginx binary "nginx" not found
nginx binary "nginx" not found
nginx binary "nginx" not found

 

In my understanding, the path dss uses to initiate the nginx binary is wrong since nginx is running on my server:

$ sudo systemctl status nginx

nginx.service - The Nginx Web Server
   Loaded: loaded (/etc/systemd/system/nginx.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2023-03-01 14:48:36 CET; 16h ago
  Process: 1560 ExecStartPost=/bin/sleep 1 (code=exited, status=0/SUCCESS)
  Process: 1520 ExecStart=/usr/local/nginx/sbin/nginx (code=exited, status=0/SUCCESS)
  Process: 1473 ExecStartPre=/usr/local/nginx/sbin/nginx -t (code=exited, status=0/SUCCESS)
 Main PID: 1536 (nginx)
    Tasks: 2
   Memory: 4.6M
   CGroup: /system.slice/nginx.service
           ├─1536 nginx: master process /usr/local/nginx/sbin/nginx
           └─1537 nginx: worker process

 

Am I correct in my assumption and where can I set the path to the nginx binary? I couldn't find the corresponding setting.

Thanks in advance, help is greatly appreciated.

 


Operating system used: RHEL7.9

0 Kudos
1 Solution
DanDy
Dataiker

Hello 

You should point your nginx to the following path /usr/sbin/nginx

You can do it with symlink command :

sudo ln -s /usr/local/nginx/sbin/nginx /usr/sbin/nginx

Stop current nginx process and restart the application.

View solution in original post

2 Replies
DanDy
Dataiker

Hello 

You should point your nginx to the following path /usr/sbin/nginx

You can do it with symlink command :

sudo ln -s /usr/local/nginx/sbin/nginx /usr/sbin/nginx

Stop current nginx process and restart the application.

Schiggy
Level 2
Author

I spent several hours on troubleshooting. You made my day! 😃

0 Kudos