Submit your inspiring success story or innovative use case to the 2022 Dataiku Frontrunner Awards! ENTER YOUR SUBMISSION

Data Science Studio startup failed on MacOS 12.3

Solved!
Mi
Level 2
Data Science Studio startup failed on MacOS 12.3

When trying to run Data Science Studio i get the following output:

***************************************************************************************************************

Starting Data Science Studio.app

dssHome:/Users/michaellappert/Library/DataScienceStudio/dss_home dssBin:/Users/michaellappert/Library/DataScienceStudio/dss_home/bin/dss

Starting Java check

/Applications/DataScienceStudio.app/Contents/Resources/kit/scripts/_find-java.sh

[Install] [+] Using Java at /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java : java version "1.8.0_321"

 

[Install] /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java

 

[Java check] EOF reached

[Java check] EOF reached

Java check terminated with status 0

Previous failed install exists, installing

[Install] *********************************************

*           Dataiku DSS installer           *

*********************************************

 

[Install] [!] *****************************************************

[!] /Users/michaellappert/Library/DataScienceStudio/dss_home contains a previously failed install of DSS

[!] Moving it out of the way and proceeding

[!] *****************************************************

 

[Install] [+] Creating data directory: /Users/michaellappert/Library/DataScienceStudio/dss_home

 

[Install] [+] Saving installation log to /Users/michaellappert/Library/DataScienceStudio/dss_home/run/install.log

 

[Install] [+] Using Java at /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java : java version "1.8.0_321"

 

[Install] [+] Checking required dependencies

 

[Install] + Detected OS distribution : osx 12.3

 

[Install] *** OS distribution not supported *** osx 12.3

 

[Install] 

[-] Dependency check failed

[-] You can install required dependencies with:

[-]    sudo -i "/Applications/DataScienceStudio.app/Contents/Resources/kit/scripts/install/install-deps.sh" -without-java

[-] You can also disable this check with the -n installer flag

 

 

[install] EOF reached

[install] EOF reached

DSS installer terminated with status 1

DSS installer failed , fatal error

 

***************************************************************************************************************

When i try sudo -i "/Applications/DataScienceStudio.app/Contents/Resources/kit/scripts/install/install-deps.sh" -without-java i get the following error:

+ Detected OS distribution : osx 12.3

*** OS distribution not supported *** osx 12.3

Is this the case? Is osx 12.3 really not supported? If so, how can i run Data Science Studio?

 

Thanks for any help and best regards

Michael


Operating system used: MacOS 12.3

0 Kudos
1 Solution
sergeyd
Dataiker
Dataiker

I assume you have recently upgraded your MacOS while the installer is the same that was downloaded previously. Please get the new installer and run DSS. 

View solution in original post

5 Replies
sergeyd
Dataiker
Dataiker

Hi @Mi 

If you are installing the latest DSS10, MacOS v12.x should be supported. 

0 Kudos
Mi
Level 2
Author

Hi @sergeyd 

Thanks for the fast reply. But i get the error output above. How do i fix this?

0 Kudos
sergeyd
Dataiker
Dataiker

I assume you have recently upgraded your MacOS while the installer is the same that was downloaded previously. Please get the new installer and run DSS. 

Mi
Level 2
Author

I actually just downloaded it before. However downloaded it again and it works now. Sorry for the inconveniences!

 

sergeyd
Dataiker
Dataiker

No problem. Glad this is resolved now.