Survey banner
Switching to Dataiku - a new area to help users who are transitioning from other tools and diving into Dataiku! CHECK IT OUT

DSS not installing on apple M1

Level 1
DSS not installing on apple M1

Hi friends, trying to install DSS in the M1 based mac and it does not complain on the OSx 11.5 but later on when precompiling Dataiku Python code. Any idea how to solve this? 

[Install] /Applications/ line 322:64762 Killed: 9 "$pythonBin" -m compileall -q "$MYDIR"/python

[-]Error precompiling Dataiku Python code (ignored)

[Install] /Applications/ line 322:64763 Killed: 9 "$pythonBin" -m compileall -q "$MYDIR"/dku-jupyter

[-]Error precompiling Jupyter Python code (ignored)


DSS installer terminated with status 137

DSS installer failed, fatal error


0 Kudos
2 Replies
Dataiker Alumni

Hi @gemma and welcome to the Dataiku Community. At this time DSS installation on Apple M1 MacBooks is not supported. We currently do not have an ETA for a compatible release. More information about M1 compatibility with DSS can be found on these threads: DSS fail to install on Mac M1DSS stratup failed 

If this is the first time you are trying out DSS and would still like to use it, we encourage you to use Dataiku Online with a 14 day free trial

This is a known limitation due to python compilation issues (not really DSS but still). Based on the community thread, you can try to workaround this by installing the Rosetta emulator:

Also, you can try an option with base Python3.7 for 


<DSS_INSTALL_DIR>/ -d <DSS_DATA_DIR> -P python3.7



I hope this helps!

Looking for more resources to help you use Dataiku effectively and upskill your knowledge? Check out these great resources: Dataiku Academy | Documentation | Knowledge Base

A reply answered your question? Mark as ‘Accepted Solution’ to help others like you!
Level 1

thanks. I tried different things now without success: (i) I installed Rosetta2 but does not allow me to open it with Rosetta2 (see screen shot below); (ii) I have also downloaded the tar.jar packages,  and run from terminal but I get the following error: 

dataiku % dataiku-dss-9.0.4-osx/ -d /egemval/dataiku/dss_data -l /egemval/dataiku/license.json -p 10000


*           Dataiku DSS installer           *


[+] Creating data directory: /egemval/dataiku/dss_data

mkdir: /egemval/dataiku/dss_data: Read-only file system

and it stops here.

(iii) I also tried to run the 

<DSS_INSTALL_DIR>/ -d <DSS_DATA_DIR> -P python3.7

but there is no file in the dss_home folder. 

note: I am not a unix expert.

0 Kudos