Announcing the winners & finalists of the Dataiku Frontrunner Awards 2021! Read their inspiring stories

Unable to use Tableau Hyper Export Plugin

Solved!
Alby92
Level 1
Level 1
Unable to use Tableau Hyper Export Plugin

Hi everyone.

I'm trying to export a dataset to .hyper format with the Tableau Hyper Export Plugin.

However, during the exporting phase, the plugin fails by returning this exception.

TableauHyperExport.PNG

I've attached the whole stack trace.

By searching on the Internet, it seems to be a problem related to a bug in the software code that checks for processors compatibility. But I couldn't find more information other than that, especially related to DSS.

I'm using DSS Community Edition (version 9.0.1) on Windows 10 by running the official Virtual Box image.

I also tried to execute the plugin on another DSS instance running directly on Ubuntu 20, but got the same error.

Do you have any clues on have to solve this problem?

Let me know if you need any additional information.

Thanks in advance.

0 Kudos
1 Solution
AlexT
Dataiker
Dataiker

Hi @Alby92 ,

The error suggests your CPU does not support the instruction sets required by the Hyper API: SSE4.2,SSE4.1, SSSE3 and POPCNT. 

You can check the instruction set supported by your DSS instance by running the command :

cat /proc/cpuinfo

Under flags, you should see the SSE*/POPCNT listed if supported. If these are not supported you will need to install DSS on a different server that supports these instruction sets to use this plugin.

On a system that has all of these available you should see something like this : 

Screenshot 2021-09-24 at 09.52.36.png

Kind Regards,

View solution in original post

0 Kudos
2 Replies
AlexT
Dataiker
Dataiker

Hi @Alby92 ,

The error suggests your CPU does not support the instruction sets required by the Hyper API: SSE4.2,SSE4.1, SSSE3 and POPCNT. 

You can check the instruction set supported by your DSS instance by running the command :

cat /proc/cpuinfo

Under flags, you should see the SSE*/POPCNT listed if supported. If these are not supported you will need to install DSS on a different server that supports these instruction sets to use this plugin.

On a system that has all of these available you should see something like this : 

Screenshot 2021-09-24 at 09.52.36.png

Kind Regards,

View solution in original post

0 Kudos
Alby92
Level 1
Level 1
Author

Hi @AlexT,

thanks for the answer.

It seems popcnt is the only instruction missing.

popcnt.PNG

The strange fact is that popcnt is missing on 4 different servers on which I've installed DSS, including the DSS official Virtual Box Image.

In my opinion these instruction sets should be added in the requirements for the plugin.

By the way, I will try to install DSS on an instance fully compatible with those instructions and I'll let you know.

In the meantime, thanks for your support.

0 Kudos
A banner prompting to get Dataiku DSS